P0340 Issue, 97 4.0L 5-Speed - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-07-2013, 02:26 AM   #1
Jeeper
 
Join Date: Jun 2013
Location: Barre, Vermont
Posts: 62
P0340 Issue, 97 4.0L 5-Speed

BACKSTORY (LOL)
So I bought a 2002 Sportster 1200 last october for $2700, its sat in my garage since only started to be moved around, Wednsday night i stopped at one of the local used car dealers to look at there always nice collection of Wranglers and spotted a nice green one with wide tires to my amazement its a 4.0L with a manual trans. AS IS on the windshield. I inquire they say it needs a passenger side air bag and brakes, So I offer my Harley In trade as I honestly had no intentions of riding with my new job.

On the ride home mind you the ride home was 11 miles, it made it almost the whole way before I downshifted and missed first and dumped it in 3rd and it stalled, so without thinking and it was slow rolling i just dumped it in first and pop'd the clutch and it pop started right up and i pulled away. I got about half a mile from that and it misfired you could feel it and the CEL came on, it ran like CRAP the rest of the ride home 2 or so miles. I put the code reader on it and it spit out a P0340 and a code for a wheel speed sensor. So I cleared the code and took it the dog and the lady for Ice cream and a few miles from the house it tripped again and ran like CRAP. So today(Thursday) I checked the plugs wires and cap and rotor they all look new. Checked the gap on the plugs as well. On a side note it ran fine today with the CEL left on.

After reading and reading on these forums someone had a link to a manual for the ignition system to test the sensor. But for whatever reason I cannot get the PDF to load on my phone computer or tablet.. Any help would be greatly appreciated.

__________________
1997 Wrangler 4.0L Sport 5-Speed Rag Top,With Some Seriously Mis-sized Tires.

1998 Dodge Ram 1500, 318, 46RE, 04 Factory 20's, Roll Pan, 1-Ton front/rear suspension
Timelord83 is offline   Quote Quick Reply
Old 06-07-2013, 12:55 PM   #2
Jeeper
 
brendend's Avatar
 
Join Date: Mar 2012
Location: colorado springs
Posts: 866
Images: 1
I have the factory service manuals at home. When i get home tonight I'll take pictures and post them. Ill find the diag tree for you also

brendend is online now   Quote Quick Reply
Old 06-07-2013, 03:52 PM   #3
Jeeper
 
Shelby427's Avatar
 
Join Date: May 2011
Location: Lakeland FL and Hooversville PA
Posts: 2,130
P0340 is normally the camshaft sensor. It's located in the distributor, under the rotor.
Nothing to changing it.
__________________
97 Sahara, 74 Renegade, 72 CJ5, 55 Willy's (the Beast) Boss 302, 6:34 gearing, Bose 901 speakers.
God I miss that Jeep. Forgot the kinda Jeep, 80 SX4.
Shelby427 is offline   Quote Quick Reply
Old 06-07-2013, 09:28 PM   #4
Jeeper
 
brendend's Avatar
 
Join Date: Mar 2012
Location: colorado springs
Posts: 866
Images: 1
Best I got for you since it seems to be a intermittent problem. Check the connection for the cmp and the wires heading back in the harness. If it looks good replace the cmp. If you are computer and mechanically savvy message me and ill send details for troubleshooting the sensor before you replace it.
brendend is online now   Quote Quick Reply
Old 06-14-2013, 08:47 PM   #5
Jeeper
 
Join Date: Jun 2013
Location: Barre, Vermont
Posts: 62
Quote:
Originally Posted by brendend View Post
Best I got for you since it seems to be a intermittent problem. Check the connection for the cmp and the wires heading back in the harness. If it looks good replace the cmp. If you are computer and mechanically savvy message me and ill send details for troubleshooting the sensor before you replace it.
Turned out to be the sensor. Thanks for the Help
__________________
1997 Wrangler 4.0L Sport 5-Speed Rag Top,With Some Seriously Mis-sized Tires.

1998 Dodge Ram 1500, 318, 46RE, 04 Factory 20's, Roll Pan, 1-Ton front/rear suspension
Timelord83 is offline   Quote Quick Reply
Reply

Tags
1997 , p0340

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 11:24 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC