P0456 code!! - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-07-2012, 11:01 PM   #1
Jeeper
 
King_Aragon's Avatar
 
Join Date: Apr 2012
Location: Hell Paso
Posts: 265
P0456 code!!

My check engine light came on today :/ I ran the code and it seems to be with the Evap control system. I will look at it tomorrow, has anyone gotten this code before and what did you do to fix it? Besides just pulling the battery to reset it :P thanks guys

King_Aragon is offline   Quote
Old 09-07-2012, 11:04 PM   #2
Jeeper
 
Join Date: Oct 2011
Posts: 1,670
Try tightening the fuel cap.

tangofox007 is offline   Quote
Old 09-07-2012, 11:12 PM   #3
Jeeper
 
King_Aragon's Avatar
 
Join Date: Apr 2012
Location: Hell Paso
Posts: 265
Quote:
Originally Posted by tangofox007
Try tightening the fuel cap.
Yup that's the first thing I tried but the code didn't erase... The Hanes manual said to check the Evap emission hoses and canister itself so that's the first thing tomorrow
King_Aragon is offline   Quote
Old 09-07-2012, 11:25 PM   #4
Jeeper
 
jameslee97206's Avatar
 
Join Date: Nov 2010
Location: Portland Oregon
Posts: 1,176
After you tightened the cap did you clear the code? I would have replaced the gas cap, cleared the code and ran it through it's drive cycles. If it throws another code I would suggest to smoke your evap system to find the leak. It's the easiest way, any shop can do it for you.
jameslee97206 is offline   Quote
Old 09-08-2012, 12:41 AM   #5
Jeeper
 
King_Aragon's Avatar
 
Join Date: Apr 2012
Location: Hell Paso
Posts: 265
Quote:
Originally Posted by jameslee97206
After you tightened the cap did you clear the code? I would have replaced the gas cap, cleared the code and ran it through it's drive cycles. If it throws another code I would suggest to smoke your evap system to find the leak. It's the easiest way, any shop can do it for you.
How would I clear the code? Sorry I'm new to my Jeep so I am still understanding her! How would I do that at a shop? Thanks
King_Aragon is offline   Quote
Old 09-08-2012, 12:51 AM   #6
Jeeper
 
jameslee97206's Avatar
 
Join Date: Nov 2010
Location: Portland Oregon
Posts: 1,176
Quote:
Originally Posted by King_Aragon View Post
How would I clear the code? Sorry I'm new to my Jeep so I am still understanding her! How would I do that at a shop? Thanks
You can clear the code with a scan tool, otherwise disconnect the battery for a few minutes and that will reset the computer.
jameslee97206 is offline   Quote
Old 09-08-2012, 09:05 AM   #7
Jeeper
 
King_Aragon's Avatar
 
Join Date: Apr 2012
Location: Hell Paso
Posts: 265
Quote:
Originally Posted by jameslee97206

You can clear the code with a scan tool, otherwise disconnect the battery for a few minutes and that will reset the computer.
That won't affect anything when I go for my emissions test? I'm from Texas that's why I ask.
King_Aragon is offline   Quote
Old 09-08-2012, 09:56 AM   #8
Jeeper
 
hagler123's Avatar
 
Join Date: May 2012
Location: Tuscaloosa, Alabama
Posts: 338
I had the same code reading large and medium evaporation emissions leak. I looked around the engine and found two badly cracked vacuum hoses I replaced those and it fixed my problem! The hoses were on the driver side under the Hood one connecting to that black box on the side and one below the vent cylinder shaped thing. If you go to my profile look at my started threads and find one that says P0455 code evap leak and I have pics of the hoses
hagler123 is offline   Quote
Old 09-08-2012, 10:51 AM   #9
Jeeper
 
jameslee97206's Avatar
 
Join Date: Nov 2010
Location: Portland Oregon
Posts: 1,176
Quote:
Originally Posted by King_Aragon

That won't affect anything when I go for my emissions test? I'm from Texas that's why I ask.
If you reset the computer you will have to drive about 50 miles for it to complete it's drive cycles before it will be ready to pass an emissions test.
__________________
Warn M8000, KD Fabworks custom cage, Homemade sliders, 4:88, D44 ARB rear, Metalcloak arms and front track bar, Currie Currectlync, BFG KM2 35's ect....ect.
jameslee97206 is offline   Quote
Old 09-08-2012, 10:27 PM   #10
Jeeper
 
King_Aragon's Avatar
 
Join Date: Apr 2012
Location: Hell Paso
Posts: 265
Quote:
Originally Posted by jameslee97206

If you reset the computer you will have to drive about 50 miles for it to complete it's drive cycles before it will be ready to pass an emissions test.
Ok so unplug negative terminal on battery and drive 50 miles before my emissions test?
King_Aragon is offline   Quote
Old 09-08-2012, 10:27 PM   #11
Jeeper
 
King_Aragon's Avatar
 
Join Date: Apr 2012
Location: Hell Paso
Posts: 265
Quote:
Originally Posted by hagler123
I had the same code reading large and medium evaporation emissions leak. I looked around the engine and found two badly cracked vacuum hoses I replaced those and it fixed my problem! The hoses were on the driver side under the Hood one connecting to that black box on the side and one below the vent cylinder shaped thing. If you go to my profile look at my started threads and find one that says P0455 code evap leak and I have pics of the hoses
Awesome thanks for the help! I'm subscribed to it so I'll look at the pictures
King_Aragon is offline   Quote
Old 09-10-2012, 05:58 PM   #12
Jeeper
 
King_Aragon's Avatar
 
Join Date: Apr 2012
Location: Hell Paso
Posts: 265
I replaced the gas cap with one from AutoZone for my Jeep. I drove 50 miles and the light is still on :/
King_Aragon is offline   Quote
Old 09-10-2012, 06:12 PM   #13
Jeeper
 
jameslee97206's Avatar
 
Join Date: Nov 2010
Location: Portland Oregon
Posts: 1,176
Quote:
Originally Posted by King_Aragon
I replaced the gas cap with one from AutoZone for my Jeep. I drove 50 miles and the light is still on :/
Re read this thread. The answer is here.
__________________
Warn M8000, KD Fabworks custom cage, Homemade sliders, 4:88, D44 ARB rear, Metalcloak arms and front track bar, Currie Currectlync, BFG KM2 35's ect....ect.
jameslee97206 is offline   Quote
Old 06-07-2013, 11:37 PM   #14
Jeeper
 
cdnabn49's Avatar
 
Join Date: Jun 2009
Location: Alberta, Canada - a displaced Texan
Posts: 155
can I see thwe pics please
__________________
~Nemo Me Impune Lacessit~
cdnabn49 is offline   Quote
Old 06-08-2013, 08:37 AM   #15
Jeeper
 
Atthehop's Avatar
 
Join Date: Jul 2008
Location: NW, NJ
Posts: 4,033
Quote:
Originally Posted by King_Aragon View Post
I replaced the gas cap with one from AutoZone for my Jeep. I drove 50 miles and the light is still on :/
Did you have them clear the codes. The will do it for free. Or stop by my house I have a code reader and can clear it for you.
__________________
Retired my 94 YJ 4cyl 5spd @ 200K
Now in a 04 TJ 4cyl 5spd CV @120K+
Both as a commuter vehicle in NW, NJ
April 2012.downsized and now a 99er.
Atthehop is offline   Quote
Old 06-08-2013, 10:37 AM   #16
Jeeper
 
King_Aragon's Avatar
 
Join Date: Apr 2012
Location: Hell Paso
Posts: 265
Quote:
Originally Posted by Atthehop View Post

Did you have them clear the codes. The will do it for free. Or stop by my house I have a code reader and can clear it for you.
It cleared itself by the ignition turning over 10x the 11th time no more code thanks though

King_Aragon is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:39 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC