P0740 Torque Converter - Circuit Malfunction - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-15-2013, 07:50 PM   #1
Jeeper
 
Catnip 0_o's Avatar
 
Join Date: Sep 2012
Location: Warren
Posts: 102
P0740 Torque Converter - Circuit Malfunction

02 TJ 145k Miles
32 RH 3 Speed

Check Engine light turned on today, pulled up the code and it read P0740 for the TC. Its strange because I had the same thing happen over a year ago and nothing came of it. I was driving one day to a buddies house and the light just came on, within a few days it turned off.

I've never had any signs of a bad TC such as slipping or oil buring. I changed my trans fluid about 4 months ago and it has been red ever since with no burnt smell.

I am curious if anyone else has ever had this issue, and if anything ever came of it? I am making a trip to Silver Lake Sand Dunes soon and I am worried I may damage something but then again, it did this over a year ago and nothing came from it.

What should I do?

Thanks

Catnip 0_o is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 06:46 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC