Passenger blinker - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-15-2014, 08:46 PM   #1
Jeeper
 
JeepandMud's Avatar
 
Join Date: Apr 2011
Location: Denver, CO
Posts: 1,538
Passenger blinker

I've looked on here at the threads in regards to a fast blinker and I think I know what to do next, but wanted to run it by all of you.

My passenger light blinks quickly and it's a constant every day thing. I changed the light bulb and found some corrosion on it so I got a whole new bulb and relay, which came with it. I also changed the drivers side even though it worked fine. Still have the quick blink. Checked the fuses and everything is in correctly and securely. So my next step/option is check the actual relay from under the fender to the housing of the light correct? Or should I check something out else first?

Thanx all in advance.

__________________
4.0L Auto '00 Solar Yellow TJ Sport, 4.25" Zone combo lift and 33x12.50 MTR Kevlars.

Always at an angle
JeepandMud is offline   Quote Quick Reply
Old 06-15-2014, 09:37 PM   #2
Jeeper
 
tbensor's Avatar
 
Join Date: Feb 2012
Posts: 1,146
Dig you check both front and rear bulbs

__________________
My Toys
2003 RED Jeep Wrangler X - Can't stop adding stuff and updating.
2014 White Jeep Liberty Sport
2011 Carbon Black GMC Yukon Denali
2007 Black GMC Sierra 2500HD 4x4 Duramax/Allison
2007 Keystone Laredo 284BHS TT
tbensor is offline   Quote Quick Reply
Old 06-15-2014, 09:40 PM   #3
Supporting Member

WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 5,581
Images: 11
Quote:
Originally Posted by JeepandMud View Post
I've looked on here at the threads in regards to a fast blinker and I think I know what to do next, but wanted to run it by all of you.

My passenger light blinks quickly and it's a constant every day thing. I changed the light bulb and found some corrosion on it so I got a whole new bulb and relay, which came with it. I also changed the drivers side even though it worked fine. Still have the quick blink. Checked the fuses and everything is in correctly and securely. So my next step/option is check the actual relay from under the fender to the housing of the light correct? Or should I check something out else first?

Thanx all in advance.
Check both the side marker light and socket on the passenger side fender flare and the parking light/turn signal light and socket in the front of the passenger side fender for corrosion or bad bulbs.
__________________
Dennis
Water Dog is offline   Quote Quick Reply
Old 06-15-2014, 10:27 PM   #4
Jeeper
 
Majnoon's Avatar
 
Join Date: Apr 2013
Location: Springfield Missouri
Posts: 3,148
Quote:
Originally Posted by Water Dog View Post
Check both the side marker light and socket on the passenger side fender flare and the parking light/turn signal light and socket in the front of the passenger side fender for corrosion or bad bulbs.
X2 I had a fast blinker. Same year as you. Better to check free stuff first. Mine happened only with headlights on. A new used turn signal switch from a junkyard neon (same as ours OEM) fixed it $15. Takes a long skinny Phillips to get it out of the neon. Test your screwdriver under your column before you go. Yours has a torx dust cover the neon don't have. While your there if the neon has intermittent wipers and you don't, upgrade that too. All of course if Waterdogs advice don't work. Good luck.
Majnoon is offline   Quote Quick Reply
Old 06-15-2014, 11:08 PM   #5
Jeeper
 
JeepandMud's Avatar
 
Join Date: Apr 2011
Location: Denver, CO
Posts: 1,538
Quote:
Originally Posted by tbensor View Post
Dig you check both front and rear bulbs
Both front and rear still work normally. Replaced both front bulbs today.

Quote:
Originally Posted by Water Dog View Post
Check both the side marker light and socket on the passenger side fender flare and the parking light/turn signal light and socket in the front of the passenger side fender for corrosion or bad bulbs.
Replaced both front bulbs today. Did notice corrosion on the inside housing unit of both front markers, but the driver's side still functions normally.
__________________
4.0L Auto '00 Solar Yellow TJ Sport, 4.25" Zone combo lift and 33x12.50 MTR Kevlars.

Always at an angle
JeepandMud is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:09 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC