Phantom Gas Whistle/Squeak - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-20-2013, 08:46 PM   #1
Jeeper
 
Herbie424's Avatar
 
Join Date: Dec 2012
Location: South Shore MA
Posts: 66
Angry Phantom Gas Whistle/Squeak

So I have searched high and low on this one and have not been able to find the culprit. I have a 99 TJ 3 Speed auto and 85% time I press on the gas (D or R) I get a squeak/whistle noise.

At first I thought it was a joint in the drive shaft, but everything feels tight. Moved onto the intake, but when in neutral or idle the noise isn't there if I press on the gas. I am replacing a front axle U-joint this weekend for it is a bit loose, but wouldn't that squeak the whole time the Jeep is moving? Could a bushing of some sort cause the squeak?

I know all jeeps have their own little squeaks, but this one just came out of the blue and is starting to bug the hell out of me

Anyone have some idea's on where to look next? Thanks in advance for the help.

Herbie424 is offline   Quote Quick Reply
Old 03-20-2013, 10:20 PM   #2
Jeeper
 
Hiatus83's Avatar
 
Join Date: Sep 2009
Location: South Jersey
Posts: 129
probably a hub bearing, listen for the noise in the morning, mine are still good but in the morning ill get an occasional squeak... would explain while its occuring in drive or reverse only.

Hiatus83 is offline   Quote Quick Reply
Old 03-21-2013, 01:59 PM   #3
Jeeper
 
Herbie424's Avatar
 
Join Date: Dec 2012
Location: South Shore MA
Posts: 66
Quote:
Originally Posted by Hiatus83 View Post
probably a hub bearing, listen for the noise in the morning, mine are still good but in the morning ill get an occasional squeak... would explain while its occuring in drive or reverse only.
Would the hub bearing cause the squeak on when on the gas or all the time?
Herbie424 is offline   Quote Quick Reply
Old 03-21-2013, 08:47 PM   #4
Jeeper
 
Hiatus83's Avatar
 
Join Date: Sep 2009
Location: South Jersey
Posts: 129
I'm not 100% sure but listen in the morning when ur car has been sitting for sometime, see if its the noise ur hearing, cause I know that if its squeaking in the am then it's most likely a shot hub bearing
Hiatus83 is offline   Quote Quick Reply
Old 03-21-2013, 08:48 PM   #5
Jeeper
 
Hiatus83's Avatar
 
Join Date: Sep 2009
Location: South Jersey
Posts: 129
Also if your accelerating ur putting more stress on the bearing as opposed to coasting to a stop
Hiatus83 is offline   Quote Quick Reply
Old 03-21-2013, 08:54 PM   #6
Jeeper
 
Herbie424's Avatar
 
Join Date: Dec 2012
Location: South Shore MA
Posts: 66
I will check it out tomorrow morning. Thanks for the input. I replaced the other hub about a month ago so maybe after 180k the other one finally went.
Herbie424 is offline   Quote Quick Reply
Old 03-25-2013, 01:30 PM   #7
Jeeper
 
HaloNHorns2002's Avatar
 
Join Date: Aug 2012
Location: Redford, MI
Posts: 43
I've noticed the same problem with my '99, just hit 186,000 miles today. It's more of a whistling noise than a squeak IMO. I too thought it might be the intake, but it’s kinda impossible to drive with your ear next to the intake, LOL. Let me know if the hub takes care of it, I’ll add that to my to-do list for the spring/summer… It keeps growing…
__________________
My "kids" -
'99 Desert Sand Wrangler Sport - TJ
'99 Emerald Mica Miata L - Henry
'07 Satin White Legacy SE wagon - Lacy
HaloNHorns2002 is offline   Quote Quick Reply
Old 03-25-2013, 02:16 PM   #8
Jeeper
 
mpbannon60's Avatar
 
Join Date: Jun 2011
Location: boothwyn pa
Posts: 101
I would still clean the iac never hurts
mpbannon60 is offline   Quote Quick Reply
Old 04-01-2013, 11:29 AM   #9
Jeeper
 
Herbie424's Avatar
 
Join Date: Dec 2012
Location: South Shore MA
Posts: 66
So I replaced both front axel u joints and both hub assembly's and while it feels a bit smoother the thud is still there. Thought it might be that transfer linkage...replaced that and still there. There is slight play in my rear axel u joint where my dv connects to my sye. Would that cause the chirp/thump on acceleration. I'm starting to think its that due to the slight sound of sparrows
Herbie424 is offline   Quote Quick Reply
Old 04-03-2013, 06:16 PM   #10
Jeeper
 
mpbannon60's Avatar
 
Join Date: Jun 2011
Location: boothwyn pa
Posts: 101
My drive shaft was barely moving I pulled it and half the u jaunt was gone and I had a thump noise and a shake
mpbannon60 is offline   Quote Quick Reply
Old 04-03-2013, 07:43 PM   #11
Jeeper
 
Herbie424's Avatar
 
Join Date: Dec 2012
Location: South Shore MA
Posts: 66
Quote:
Originally Posted by mpbannon60 View Post
My drive shaft was barely moving I pulled it and half the u jaunt was gone and I had a thump noise and a shake
Yea I'm going to replace my cv this weekend. New parts should be here tomorrow. I'll keep ya posted

Herbie424 is offline   Quote Quick Reply
Reply

Tags
gas pedal , squeak , whistle

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:12 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC