Right brake light problem! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-05-2013, 10:09 PM   #1
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
Right brake light problem!

When i press my brakes in my 04 rubicon my right light will not turn on, but when parking lights are on the light will turn on but will not get bright when brake is pressed.

jeepr1106 is offline   Quote Quick Reply
Old 07-05-2013, 10:21 PM   #2
Supporting Member

WF Supporting Member
 
JimsJeep's Avatar
 
Join Date: Feb 2012
Location: Long Branch NJ
Posts: 997
Might be as simple as a bit of corrosion in the socket. Best place to start.

JimsJeep is offline   Quote Quick Reply
Old 07-05-2013, 10:46 PM   #3
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
they are led lights in wired in Parallel
jeepr1106 is offline   Quote Quick Reply
Old 07-06-2013, 07:14 AM   #4
Jeeper
 
Atthehop's Avatar
 
Join Date: Jul 2008
Location: NW, NJ
Posts: 3,705
Check your grounds, tail lamps ground with the mounting screws.
__________________
Retired my 94 YJ 4cyl 5spd @ 200K
Now in a 04 TJ 4cyl 5spd CV @120K+
Both as a commuter vehicle in NW, NJ
April 2012.downsized and now a 99er.
Atthehop is offline   Quote Quick Reply
Old 07-06-2013, 07:24 AM   #5
Jeeper
 
Redrider94's Avatar
 
Join Date: Aug 2010
Posts: 625
Does your right turn signal work when you turn it on? If your turn signal works then I'd say that you may have a problem with your turn signal switch. If turn signal is not working them I'd look for a break in the brake light wiring.
Redrider94 is offline   Quote Quick Reply
Old 07-06-2013, 05:07 PM   #6
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
I figured it out, previous owner removed third brake light and left the wires open and not completing the circuit. i just put a load between the + and - and it fixed the problem
jeepr1106 is offline   Quote Quick Reply
Old 07-06-2013, 07:29 PM   #7
Jeeper
 
freeskier's Avatar
 
Join Date: Mar 2011
Location: Longmont, CO
Posts: 2,368
Quote:
Originally Posted by jeepr1106 View Post
I figured it out, previous owner removed third brake light and left the wires open and not completing the circuit. i just put a load between the + and - and it fixed the problem
Not sure how this fixed the problem, can't remember the last time I had a third brake light and that certainly hasn't given me problems.

Your issue sounded like a bad ground.

Your wirings seems funky.
__________________
CU Boulder Aerospace Engineering
freeskier is offline   Quote Quick Reply
Old 08-05-2013, 02:46 AM   #8
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
Ok problem is back
jeepr1106 is offline   Quote Quick Reply
Old 08-05-2013, 02:55 AM   #9
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
Click image for larger version

Name:	ForumRunner_20130804_215508.jpg
Views:	35
Size:	82.1 KB
ID:	281799



Click image for larger version

Name:	ForumRunner_20130804_215443.png
Views:	36
Size:	185.3 KB
ID:	281798

This is what it looks like
jeepr1106 is offline   Quote Quick Reply
Old 08-05-2013, 05:55 AM   #10
OIIIIIO

WF Supporting Member
 
T2000J's Avatar
 
Join Date: Sep 2010
Location: PA
Posts: 885
Quote:
Originally Posted by jeepr1106 View Post

This is what it looks like
I'd say ground problem them cages tend to be a PITA . My first Tj had them they worked then didn't work . Take a wire hook it to your bumper and put the other end to your light .
__________________


JEEP WRANGLER
T2000J is offline   Quote Quick Reply
Old 08-05-2013, 09:28 AM   #11
Old School

WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 4,010
Images: 11
Quote:
Originally Posted by redrider94 View Post
does your right turn signal work when you turn it on?
x2..??
__________________
Dennis
Water Dog is online now   Quote Quick Reply
Old 08-05-2013, 10:31 AM   #12
Jeeper
 
freeskier's Avatar
 
Join Date: Mar 2011
Location: Longmont, CO
Posts: 2,368
Quote:
Originally Posted by T2000J View Post

I'd say ground problem them cages tend to be a PITA . My first Tj had them they worked then didn't work . Take a wire hook it to your bumper and put the other end to your light .
They are LEDs which means they are no longer grounded through the mounts. Looks like bad wiring job or multi function switch.

OP does the right blinker work?
__________________
CU Boulder Aerospace Engineering
freeskier is offline   Quote Quick Reply
Old 08-05-2013, 01:13 PM   #13
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
Huh
jeepr1106 is offline   Quote Quick Reply
Old 08-05-2013, 02:31 PM   #14
Old School

WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 4,010
Images: 11
Quote:
Originally Posted by jeepr1106 View Post
Huh
Huh what? Does the right turn signal work????
__________________
Dennis
Water Dog is online now   Quote Quick Reply
Old 08-05-2013, 03:07 PM   #15
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
No it is also dim, but when I turn on parking lights it gets brighter
jeepr1106 is offline   Quote Quick Reply
Old 08-05-2013, 03:31 PM   #16
Old School

WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 4,010
Images: 11
I think Freeskier is right....probably miswired.
__________________
Dennis
Water Dog is online now   Quote Quick Reply
Old 08-05-2013, 04:06 PM   #17
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
How is it supposed to be wired, there is a black, green and red wire coming from the light
jeepr1106 is offline   Quote Quick Reply
Old 08-05-2013, 04:57 PM   #18
OIIIIIO

WF Supporting Member
 
T2000J's Avatar
 
Join Date: Sep 2010
Location: PA
Posts: 885
Past few LEDs had different pigtails on them YOUR colors I can't say but the jeep Harness is so :
Purple/black = reverse light
Black/yellow = taillight
Green /red = (left) turn/stop
Brown/ red = (right) turn/stop
__________________


JEEP WRANGLER
T2000J is offline   Quote Quick Reply
Old 08-05-2013, 05:21 PM   #19
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
The wiring is good. Idk what the problem is
jeepr1106 is offline   Quote Quick Reply
Old 08-05-2013, 06:34 PM   #20
Old School

WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 4,010
Images: 11
I would try disconnecting the led's and use a test light to test the jeep wiring. If that works, then you know it's in the led circuitry or a ground, if it doesn't work with a standard test light, then it's probably the multifuntion switch. (You'll have to check it there.)
__________________
Dennis
Water Dog is online now   Quote Quick Reply
Old 08-05-2013, 06:57 PM   #21
Jeeper
 
freeskier's Avatar
 
Join Date: Mar 2011
Location: Longmont, CO
Posts: 2,368
Quote:
Originally Posted by Water Dog View Post
I would try disconnecting the led's and use a test light to test the jeep wiring. If that works, then you know it's in the led circuitry or a ground, if it doesn't work with a standard test light, then it's probably the multifuntion switch. (You'll have to check it there.)
Yup, if it's not the lights or wiring the multifunction switch is the next likeliest thing to check. Everything goes through it and it doesn't take much fore the traces in there to short with each other. I've had mine open 3 or 4 times now to fix it.
__________________
CU Boulder Aerospace Engineering
freeskier is offline   Quote Quick Reply
Old 08-05-2013, 07:15 PM   #22
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
Were is it
jeepr1106 is offline   Quote Quick Reply
Old 08-05-2013, 07:31 PM   #23
Old School

WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 4,010
Images: 11
It's the turn signal switch on the steering column
__________________
Dennis
Water Dog is online now   Quote Quick Reply
Old 08-05-2013, 07:46 PM   #24
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
Could I get a picture?
jeepr1106 is offline   Quote Quick Reply
Old 08-05-2013, 08:05 PM   #25
Old School

WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 4,010
Images: 11
Quote:
Originally Posted by jeepr1106 View Post
Could I get a picture?
The only picture I have is the one off a "99", yours probably has the headlights on it as well.
Attached Thumbnails
Click image for larger version

Name:	MF Switch.jpg
Views:	9
Size:	73.8 KB
ID:	282140  
__________________
Dennis
Water Dog is online now   Quote Quick Reply
Old 08-05-2013, 09:02 PM   #26
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
Ok so, when the parking lights are on the light works. When harzards are on, right turn signal and brakes are pressed its dim
jeepr1106 is offline   Quote Quick Reply
Old 08-05-2013, 09:50 PM   #27
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
What do I do when I open it
jeepr1106 is offline   Quote Quick Reply
Old 08-05-2013, 10:42 PM   #28
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
I check all the pins they look good
jeepr1106 is offline   Quote Quick Reply
Old 08-09-2013, 11:59 PM   #29
Newb
 
Join Date: Feb 2012
Posts: 9
Exactly the same thing happened to me when I put LED bulbs in my TJ. Don't want to sound too technical, but you have to install 2 blocking diodes for the rear lights and 2 for the front turn signal/park lights. Also, since I didn't want to use load resistors to force the blinkers to work, I swapped out the blinker module for an electronic one made for LEDs.
bigal66 is offline   Quote Quick Reply
Old 08-10-2013, 12:16 AM   #30
Jeeper
 
jeepr1106's Avatar
 
Join Date: May 2013
Location: Kailua
Posts: 90
So if I can replace that relay

jeepr1106 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:42 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC