rough idle - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-14-2009, 10:22 PM   #1
Jeeper
 
Hensman's Avatar
 
Join Date: May 2009
Location: Pleasanton, CA
Posts: 322
rough idle

I know what you guys are saying, go look at all of the other rough idle threads, but I have and none of them seem to fit exactly what I have. So I've cleaned the IAC, ran two bottles of fuel injector cleaner in it, and just recenlty replaced the spark plugs, but nothing has changed. What else could it be?

__________________
2005 TJ Unlimited 4.0 6 speed
LoD expedition series rear bumper/tire carrier, BFG A/T 32x11.5x15, OME 2.5 w/ lj springs
Hensman is offline   Quote Quick Reply
Old 07-14-2009, 10:26 PM   #2
Senior Member
 
Join Date: Sep 2008
Posts: 2,775
What's rough about it? Vibrations or does it seem to be missing?

If it's vibs, check the belt for tightness.

If the belt's tight and/or its missing instead, may be the o2 sensor. No codes I assume?

stevens243 is offline   Quote Quick Reply
Old 07-14-2009, 10:29 PM   #3
Jeeper
 
Hensman's Avatar
 
Join Date: May 2009
Location: Pleasanton, CA
Posts: 322
A little bit of both but more of a missing and yeah, no codes at all and the rpm's dont change.
__________________
2005 TJ Unlimited 4.0 6 speed
LoD expedition series rear bumper/tire carrier, BFG A/T 32x11.5x15, OME 2.5 w/ lj springs
Hensman is offline   Quote Quick Reply
Old 07-14-2009, 10:33 PM   #4
Senior Member
 
Join Date: Sep 2008
Posts: 2,775
checking the belt is free and quick and simple.
stevens243 is offline   Quote Quick Reply
Old 07-15-2009, 03:56 AM   #5
Jeeper
 
Hensman's Avatar
 
Join Date: May 2009
Location: Pleasanton, CA
Posts: 322
Ok, I'll give it a look tomorrow and forgot to mention that when i turn the AC on, the roughness is cut in half, Idk how that could make any difference, but it does...
__________________
2005 TJ Unlimited 4.0 6 speed
LoD expedition series rear bumper/tire carrier, BFG A/T 32x11.5x15, OME 2.5 w/ lj springs
Hensman is offline   Quote Quick Reply
Old 07-15-2009, 10:34 AM   #6
Jeeper
 
jwm1986's Avatar
 
Join Date: Dec 2008
Location: Evansville, IN
Posts: 1,024
Mine has always had a rough idle. I seafomed it twice, replaced spark plugs, cleaned throttle body and IAC, checked TPS, new exhaust (nothing to do with idle), and none of that made any difference at all. I replaced my rear o2 due to a CEL and it got a little better but still does it. But it's not all the time now.

I cannot figure it out and no longer care. It's just a part of my jeep apparently.
__________________
2000 Jeep Wrangler Sport
4.0L / 5spd
jwm1986 is offline   Quote Quick Reply
Old 07-16-2009, 02:19 AM   #7
Jeeper
 
Hensman's Avatar
 
Join Date: May 2009
Location: Pleasanton, CA
Posts: 322
Well I checked the belt and it is in good shape and is tight. I know that some engines just run a little rough, but I would think that there would have to be something wrong that I could fix to make it not so rough. I wouldn't think its good for the engine.
__________________
2005 TJ Unlimited 4.0 6 speed
LoD expedition series rear bumper/tire carrier, BFG A/T 32x11.5x15, OME 2.5 w/ lj springs
Hensman is offline   Quote Quick Reply
Old 07-16-2009, 02:04 PM   #8
Jeeper
 
meyers's Avatar
 
Join Date: Apr 2009
Location: Dover, New Hampshire
Posts: 738
While I was home from the Sandbox and drove our Jeep first thing I noticed was the rough, non-consistent Idle. Just on whim I bought a can of Sea foam, put most of it in a tank with an 1/8 of gas left. I then pulled the intake tube off the TB and dumped Sea foam in the IAC slot a bit at a time till the engine started to choke and smoke a bit. After about five minutes of the smoke and choke dying out I took it for a run and it was instantly better. Even Nikki who didn't notice the idle before says it runs at lower RPM and she sees the Mileage is better. I am going to make this part of my maintenance ritual on the Jeep.
meyers is offline   Quote Quick Reply
Old 07-16-2009, 02:56 PM   #9
Jeeper
 
Hensman's Avatar
 
Join Date: May 2009
Location: Pleasanton, CA
Posts: 322
Yeah, I've seafoamed my truck before and it worked pretty well, it's just that I replaced my plugs about a month ago and I heard that they can mess up the plugs.
__________________
2005 TJ Unlimited 4.0 6 speed
LoD expedition series rear bumper/tire carrier, BFG A/T 32x11.5x15, OME 2.5 w/ lj springs
Hensman is offline   Quote Quick Reply
Old 07-16-2009, 11:12 PM   #10
Jeeper
 
603TJ's Avatar
 
Join Date: Apr 2008
Location: New Hampshire
Posts: 191
Throttle Position Sensor?
__________________
98TJ. wheels. shocks. motor. other things that make a jeep move.
603TJ is offline   Quote Quick Reply
Old 07-17-2009, 12:26 AM   #11
Jeeper
 
Hensman's Avatar
 
Join Date: May 2009
Location: Pleasanton, CA
Posts: 322
Maybe??? Do you have experience with that?
__________________
2005 TJ Unlimited 4.0 6 speed
LoD expedition series rear bumper/tire carrier, BFG A/T 32x11.5x15, OME 2.5 w/ lj springs
Hensman is offline   Quote Quick Reply
Old 07-17-2009, 07:07 AM   #12
Jeeper
 
meyers's Avatar
 
Join Date: Apr 2009
Location: Dover, New Hampshire
Posts: 738
Quote:
Originally Posted by Hensman View Post
Yeah, I've seafoamed my truck before and it worked pretty well, it's just that I replaced my plugs about a month ago and I heard that they can mess up the plugs.

I dunno about others but in this case I am using the same plugs and never even pulled them. Runs great
meyers is offline   Quote Quick Reply
Old 02-03-2013, 05:25 PM   #13
Newb
 
Join Date: Jan 2013
Posts: 1
Quote:
Originally Posted by Hensman View Post
I know what you guys are saying, go look at all of the other rough idle threads, but I have and none of them seem to fit exactly what I have. So I've cleaned the IAC, ran two bottles of fuel injector cleaner in it, and just recenlty replaced the spark plugs, but nothing has changed. What else could it be?
I had a mechanic tell me it is caused by the 2 rear injectors getting hot because there is no insulation between them and the block. I beleive it affects the 04 thru 06 Wranglers.The warmer the engine the worse the problem. I think there is an after market kit to remedy the problem. Good luck
billlscott is offline   Quote Quick Reply
Old 02-03-2013, 10:04 PM   #14
Jeeper
 
Neltronic's Avatar
 
Join Date: Aug 2012
Location: Irvine
Posts: 287
Mine runs rough as well, Replaced the plugs with double-platinum and new wires last weekend, runs a bit better but still rough. Next is getting the fuel system/injectors cleaned and tuned up. I don't think it's ever been cleaned, at least according to the notes the PO kept in the manual.

Neltronic is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle? Washing? AndyLA JK Tech Forum 4 04-22-2009 11:13 AM
4.2 rough idle and stalling problem truemainer150 YJ Tech Forum 9 04-12-2008 06:10 PM
rough idle spanky TJ Tech Forum 9 04-08-2008 05:25 PM
rough idle for 5 or 10 minutes... Jonny15 TJ Tech Forum 5 04-02-2008 08:34 PM
Hard starting, rough idle, with CEL jfcjr TJ Tech Forum 4 05-24-2006 01:26 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:12 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC