rough Idle in heavy Traffic - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-19-2009, 03:24 PM   #1
Jeeper
 
AKWrangler's Avatar
 
Join Date: Oct 2008
Location: Alaska
Posts: 83
rough Idle in heavy Traffic

I have a wierd problem, maybe you guys can help out. When I am in Heavy Traffic and we start moving a few feet, I will engage the clutch and accelerate the few feet then Brake, my RPM's will drop too low, the Jeep will shudder then it readjusts itself back to Idle, but if I don't brake and let it come to a stop on it's own, it's fine. it's all tuned up new plugs etc.. and the motor is all warmed up. Any Ideas?

AKWrangler is offline   Quote
Old 12-19-2009, 03:32 PM   #2
Jeeper
 
Atthehop's Avatar
 
Join Date: Jul 2008
Location: NW, NJ
Posts: 3,963
Sounds like the TPS is acting up. They are easy to replace and not very expensive.

__________________
Retired my 94 YJ 4cyl 5spd @ 200K
Now in a 04 TJ 4cyl 5spd CV @120K+
Both as a commuter vehicle in NW, NJ
April 2012.downsized and now a 99er.
Atthehop is offline   Quote
Old 12-19-2009, 03:38 PM   #3
Jeeper
 
AKWrangler's Avatar
 
Join Date: Oct 2008
Location: Alaska
Posts: 83
thanks for the quick answer, I will see if I can get a replacement for it. Do I need to go to a dealer for that or can I get that in a parts store like NAPA?
AKWrangler is offline   Quote
Old 12-19-2009, 04:10 PM   #4
Jeeper
 
Atthehop's Avatar
 
Join Date: Jul 2008
Location: NW, NJ
Posts: 3,963
They sell them aftermarket but I have seen in other threads thay they are not as good. I use OEM whenever I can.
__________________
Retired my 94 YJ 4cyl 5spd @ 200K
Now in a 04 TJ 4cyl 5spd CV @120K+
Both as a commuter vehicle in NW, NJ
April 2012.downsized and now a 99er.
Atthehop is offline   Quote
Old 12-20-2009, 06:30 AM   #5
Jeeper
 
AKWrangler's Avatar
 
Join Date: Oct 2008
Location: Alaska
Posts: 83
Quote:
Originally Posted by Atthehop View Post
They sell them aftermarket but I have seen in other threads thay they are not as good. I use OEM whenever I can.
thanks for the info.
AKWrangler is offline   Quote
Old 12-20-2009, 02:08 PM   #6
Jeeper
 
VARedLeg82's Avatar
 
Join Date: Oct 2009
Location: Schofield Barracks, HI
Posts: 76
I'd try cleaning out the throttle body first. Just get in there with a paper towel and some carb cleaner. I've had the same problem in the past and getting the gunk out of the TB cleared it right up.

VARedLeg82 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rough idle Hensman TJ Tech Forum 13 02-03-2013 10:04 PM
4.0 Hard Start / Backfire / Rough Run after extended idle biasdesign YJ Tech Forum 1 12-29-2009 07:49 PM
Rough Idle and Starting Issue crashnburn54 TJ Tech Forum 6 10-30-2009 10:11 AM
Rough Idle? Washing? AndyLA JK Tech Forum 4 04-22-2009 11:13 AM
4.2 rough idle and stalling problem truemainer150 YJ Tech Forum 9 04-12-2008 06:10 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:27 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC