running rich still - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-07-2008, 08:32 AM   #1
Newb
 
Join Date: Dec 2008
Location: hudson, florida
Posts: 7
running rich still

hi i'm new to this forum, and have been reading up on my problem. I have a 97 tj 2.5 4 cyl, 128,000miles. i bought it a couple months ago. seemed to run fine but the cel light was on. had it checked and it had bad o2 upstream, and multiple misfire. changed o2 sensor and plugs, wires, cap, rotor, oil, thermostat, normal tune up. ran good for a day. then it started idling like crap and blowing black smoke. now throws code 51 and 52. too rich and too lean. i've now replaced exhaust manifold, downstream o2, checked for vaccum leaks and iac. still running rich and crappy idle. any ideas would be greatly appreciated. thanks in advance

achappy44 is offline   Quote Quick Reply
Old 12-07-2008, 11:52 AM   #2
Jeeper
 
Rawkon's Avatar
 
Join Date: Apr 2005
Location: fullerton/big bear
Posts: 2,061
Send a message via AIM to Rawkon Send a message via MSN to Rawkon
return and try replacing the original 02 you replaced. sounds like its bad or they gave you the wrong thing. also are you sure plug wires are in the correct location??? what plugs did you use?

Rawkon is offline   Quote Quick Reply
Old 12-07-2008, 12:05 PM   #3
Newb
 
Join Date: Dec 2008
Location: hudson, florida
Posts: 7
i thought it might be the 02 also but why wouldn't it come up in a code
i think they were bosch plugs but don't remember.
achappy44 is offline   Quote Quick Reply
Old 12-07-2008, 01:45 PM   #4
Newb
 
Join Date: Dec 2008
Location: hudson, florida
Posts: 7
thanx for the reply i changed the o2 sensor and the cel went off never by universal and thank baby jesus for warranties at autozone.
achappy44 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine running too rich...High Compression Jb1234 TJ Tech Forum 10 11-26-2008 08:20 PM
Ya think he's running a bit rich? 02Prove Off-Topic 7 03-14-2008 08:29 PM
4.2 Running rich MrJarratt YJ Tech Forum 5 11-25-2007 09:30 PM
Running rich.....? NY94YJ YJ Tech Forum 3 11-17-2007 09:52 AM
Engine Running Very Rich!!! crickifur YJ Tech Forum 24 09-23-2007 11:24 AM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:28 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC