Same Old Heating Issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-14-2009, 12:40 PM   #1
Jeeper
 
Join Date: Jun 2009
Posts: 69
Images: 5
Same Old Heating Issue

I tried and couldn't find some previous threads on this.

I bought my Jeep back in June from a buddy. I knew the heat wasn't working that well. The fan blows great, but it's just not getting "hot air" into the cabin.

I really don't want to do the dashboard teardown to get to the core unless needed. Aren't there some other tricks to clear a plugged core?

Thanks

thanley is offline   Quote
Old 10-14-2009, 03:03 PM   #2
Jeeper
 
snwchris's Avatar
 
Join Date: Jan 2009
Location: NE Ohio
Posts: 1,718
First check the vacuum line under the hood that connects to the barb on the engine, (rear drivers side).

If that's not it, check the vaccum lines to the control panel, by simple removing the couple of scerws for the center dash bezel.

Next would check fuses.

After having vehicle run til warm, check hoses going into firewall. if one is significantly colder, unhook and flush hose.

Chris

__________________
98TJ / Hi-Lined / Zip Lockers / 35s


Family Rig / Tow Rig: 08 Tundra & 16ft Trailer
snwchris is offline   Quote
Old 10-14-2009, 03:03 PM   #3
Jeeper
 
gaddman's Avatar
 
Join Date: Aug 2009
Location: South Carolina
Posts: 49
You can try and backflush the heater core. Simple process that I've done on my wife's VW and worked like a charm with no harm to the core at all.
__________________
Alan

97 Sahara

gaddman is offline   Quote
Old 10-14-2009, 04:18 PM   #4
Newb
 
Join Date: Oct 2009
Location: texarkana
Posts: 13
if the thermostat has been removed will it blow lukewarm air?
ghettocowboy is offline   Quote
Old 10-14-2009, 09:21 PM   #5
Newb
 
Mocaco_Luc's Avatar
 
Join Date: Sep 2009
Location: Ocean State
Posts: 12
im having the same issue with no hot air coming out. the heat is very minor to almost nothing. mine is a 1999.
Mocaco_Luc is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough running TJ - Electric or Fuel issue?? 666 TJ General Discussion Forum 4 07-01-2012 11:00 AM
Electrical issue that keeps getting worse... fourtyoneantz TJ Tech Forum 2 06-28-2010 07:31 PM
JK Photo Essay in Next Issue of JPFreek txoutdoorx4 JK General Discussion Forum 2 10-19-2007 09:49 AM
New Issue of JPFreek Adventure Magazine available now! txoutdoorx4 General Jeep Discussion 2 10-11-2007 12:53 PM
Anniversary issue of JPFreek Adventure Mag available Mon, 4/9 txoutdoorx4 Off-Topic 0 04-08-2007 07:54 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 06:44 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC