Sensor Problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-26-2010, 05:56 PM   #1
Newb
 
Join Date: Oct 2010
Location: Virginia Beach, VA
Posts: 3
Sensor Problems

Hi folks!

So I recently bought a 98 Wrangler 4cyl 2.5L with about 120k miles. Soon as I bought it I had to replace the transmission to get it road worthy. Ran fine for about 500 miles then the check engine light came on and it started running rough. The code that came up was P0202 which is injector 2 circuit malfunction. Anyways, I did some research online and many said it was most likely the crankshaft position sensor, not the injector sensor. So I replaced the crankshaft position sensor and it ran great for about another 300 miles. Then I noticed minor hesitation every once in a while at around 2k rpms. It didn't happen often so I ignored it but then the check engine light came on again. This time, three codes: P0202 (injector 2 circuit), P0463 (fuel level sensor), and P1391 (Intermittent loss of Camshaft Position Sensor or Crankshaft Position Sensor). Well since I already replaced the CKP I figured it must be the CMP which after doing some more research is apparently the distributor switch plate. I cleaned the part first because I didn't want to spend $80 on it if I didn't have to, but now it smells like it's running reeeally rich and runs like crap. So I ordered a new distributor switch plate which should be here in a few days, but has anyone else encountered problems like these and is there something I should look at specifically? I really appreciate any help or advice you have!!

-Nate

nywrangler is offline   Quote Quick Reply
Old 11-01-2010, 09:57 PM   #2
Newb
 
Join Date: Oct 2010
Location: Virginia Beach, VA
Posts: 3
Alrighty, so the new camshaft position sensor finally came and it seems to be working good so far. No hesitation and the check engine light is off. Now the only thing that seems to be acting up is the fuel gauge. Not sure what that is all about and why it would act up after replacing the CMP.

nywrangler is offline   Quote Quick Reply
Old 11-01-2010, 10:06 PM   #3
Jeeper
 
Join Date: Oct 2010
Location: Conway, AR
Posts: 201
Well, you had a code for the fuel level sensor previously, right? Did you disconnect the battery at any point while working on it/replacing the CPS? If so it could have temporarily cleared the code, and will probably come back. Takes a few days/miles for the computer to get pissed over little stuff like that. =P
__________________
"Damn this traffic jam, how I hate to be late. It hurts my motor to go so slow.."
toxictv is offline   Quote Quick Reply
Old 11-02-2010, 06:47 PM   #4
Newb
 
Join Date: Oct 2010
Location: Virginia Beach, VA
Posts: 3
The light did turn off by itself but after about 40 miles, it's back on and hesitating intermittently again. This time only codes P0202 and P0463. I've already replaced the injector for cylinder 2 so I'm not sure whats throwing that code. For the other code, I really don't want to shell out $250 for the freakin fuel pump/sensor but it's looking like I'll have to.
nywrangler is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:48 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC