Spark Plugs Now Check Engine Light... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-17-2010, 09:27 PM   #1
Jeeper
 
Jon M's Avatar
 
Join Date: Aug 2010
Location: Deland, FL
Posts: 406
Spark Plugs Now Check Engine Light...

Well, changed out the plugs today. Put the rail back on. Apparently miss 2 plugs, unknowing this started engine. Heard knocking sound of cyl not firing I guess. Turned engine off but at same time check engine came on. Redid the rail and engine sounds fine but engine light still on. Comes up with code p0305 which would match the plug boot I missed. Anyway, please chime in with some insight. Thank you all.

__________________
'02 TJ Sport, Dana 44, 5spd, 31" GY DuraTrac's, Spiderweb Shadecage, Zone 2" BB w/Quick Discos
Jon M is offline   Quote Quick Reply
Old 12-17-2010, 09:38 PM   #2
Jeeper
 
jasonwrangler's Avatar
 
Join Date: Oct 2010
Location: Omaha, NE
Posts: 892
clear the code maybe?

jasonwrangler is offline   Quote Quick Reply
Old 12-17-2010, 10:10 PM   #3
Jeeper
 
DevilDogDoc's Avatar
 
Join Date: Jun 2010
Location: Yucca Valley CA 20 miles from JV
Posts: 2,362
It'll go off in a few starts. Ignore it until then, or unplug the battery.
__________________
Violence may not be the answer but it sure cuts down on the stupid questions
DevilDogDoc is offline   Quote Quick Reply
Old 12-17-2010, 10:41 PM   #4
Moderator

WF Supporting Member
::WF Moderator::
 
doclouie's Avatar
 
Join Date: Feb 2010
Location: In the mountains.
Posts: 3,606
Images: 4
X2-it will clear itself after so many starts. Do not worry about it.
__________________
2000 Sahara, 3.5" Rubicon Express Lift, 1" spring spacer & 1" Body Lift, 33" or 35" BFG Mud tires, Front & Rear ARB, Rancho 9000 shocks, UCF Ultra High Belly Up

doclouie is offline   Quote Quick Reply
Old 12-18-2010, 09:23 AM   #5
Jeeper
 
Jon M's Avatar
 
Join Date: Aug 2010
Location: Deland, FL
Posts: 406
Thanks, got real nervous when I first started up and heard the knocking. Looked at 4x4explor and jeep.us41.org and they mentioned missing the plug boots when putting the rail back on. I'm not the most mechanically inclined but wanted to do this myself since I've heard maintenence on the 4.0 is so simple. Now just need to get the oil done and flush the radiator since I don't know if the previous owner did it at the 60 month mark. Saw in the owners manual to do it at 60 months or 100K miles. Also talked to a mechanic buddy of mine and he said as long as I'm not wheeling through water not to worry about the transfer case and differentials until 60K miles. What do you guys think?
__________________
'02 TJ Sport, Dana 44, 5spd, 31" GY DuraTrac's, Spiderweb Shadecage, Zone 2" BB w/Quick Discos
Jon M is offline   Quote Quick Reply
Old 12-18-2010, 09:35 AM   #6
Moderator

WF Supporting Member
::WF Moderator::
 
doclouie's Avatar
 
Join Date: Feb 2010
Location: In the mountains.
Posts: 3,606
Images: 4
I always take the approach that the previous owner did nothing to my new vehicle and I change out most everything that can be changed. You will learn a bit by doing services earlier and know it has been done right. As for the trans and diff I would take the same approach and assume the last guy wheeled it in water. That way you will know exactly where everything stands.
__________________
2000 Sahara, 3.5" Rubicon Express Lift, 1" spring spacer & 1" Body Lift, 33" or 35" BFG Mud tires, Front & Rear ARB, Rancho 9000 shocks, UCF Ultra High Belly Up

doclouie is offline   Quote Quick Reply
Old 12-18-2010, 09:42 AM   #7
Jeeper
 
Jon M's Avatar
 
Join Date: Aug 2010
Location: Deland, FL
Posts: 406
Actually I did research the previous owner. He was an old man who used it to golf on the weekends. Was a local jeep. No mods what so ever. Had Just under 27K miles when I bought it this past August. Was garage kept. Fenders are still black and shiney. Had original tires. Has original top, etc.... Anyway to check the diff's for water prior to pulling them apart?
__________________
'02 TJ Sport, Dana 44, 5spd, 31" GY DuraTrac's, Spiderweb Shadecage, Zone 2" BB w/Quick Discos
Jon M is offline   Quote Quick Reply
Old 12-18-2010, 01:04 PM   #8
Jeeper
 
Neil F.'s Avatar
 
Join Date: Nov 2007
Location: Marlton, NJ
Posts: 4,593
Images: 1
You can pull the plugs and stick your finger in. If there was water, it will look like a milk shake. If it was babied by and older man, I doubt there was any chance of water getting in.
__________________
2003 TJ, 33" BFG AT, 2" BL, 2" BDS spring lift, 55w DDM HIDs
Neil F. is offline   Quote Quick Reply
Old 12-18-2010, 05:21 PM   #9
Jeeper
 
Jon M's Avatar
 
Join Date: Aug 2010
Location: Deland, FL
Posts: 406
Thx
__________________
'02 TJ Sport, Dana 44, 5spd, 31" GY DuraTrac's, Spiderweb Shadecage, Zone 2" BB w/Quick Discos
Jon M is offline   Quote Quick Reply
Old 12-18-2010, 06:36 PM   #10
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 29,208
Images: 2
Disconnect the battery's negative lead for two minutes, that'll clear the codes.
__________________
When you have a choice, buy American.

Jerry Bransford is online now   Quote Quick Reply
Old 12-18-2010, 07:00 PM   #11
Jeeper
 
Jon M's Avatar
 
Join Date: Aug 2010
Location: Deland, FL
Posts: 406
I was wondering when u were gonna chime in on this one. Thanks for the info. Will try in the morning.
__________________
'02 TJ Sport, Dana 44, 5spd, 31" GY DuraTrac's, Spiderweb Shadecage, Zone 2" BB w/Quick Discos
Jon M is offline   Quote Quick Reply
Old 12-21-2010, 08:51 AM   #12
Jeeper
 
Jon M's Avatar
 
Join Date: Aug 2010
Location: Deland, FL
Posts: 406
It was wierd, disconnected the battery. It reset the engine light and there were no codes coming up. But then for a while the engine would turn over and run but would then idle down and stall. It's running fine now though after a while going down the road it went back to normal. Anyone know if that is normal???
__________________
'02 TJ Sport, Dana 44, 5spd, 31" GY DuraTrac's, Spiderweb Shadecage, Zone 2" BB w/Quick Discos
Jon M is offline   Quote Quick Reply
Old 12-21-2010, 09:21 AM   #13
Jeeper

WF Supporting Member
 
wranglernut's Avatar
 
Join Date: Sep 2010
Location: How does that saying go... I wasn't born in Texas but I got here as soon as I could! :)
Posts: 150
Quote:
Originally Posted by Jon M
It was wierd, disconnected the battery. It reset the engine light and there were no codes coming up. But then for a while the engine would turn over and run but would then idle down and stall. It's running fine now though after a while going down the road it went back to normal. Anyone know if that is normal???
That happens to me too... Got really worried the first time but it only ever happens after disconnecting the battery. Don't know if it's normal but at least it's nice to have company!!
wranglernut is offline   Quote Quick Reply
Old 12-21-2010, 09:40 AM   #14
Jeeper
 
Jon M's Avatar
 
Join Date: Aug 2010
Location: Deland, FL
Posts: 406
Thx
__________________
'02 TJ Sport, Dana 44, 5spd, 31" GY DuraTrac's, Spiderweb Shadecage, Zone 2" BB w/Quick Discos
Jon M is offline   Quote Quick Reply
Old 12-21-2010, 09:57 AM   #15
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 29,208
Images: 2
Quote:
Originally Posted by wranglernut View Post
That happens to me too... Got really worried the first time but it only ever happens after disconnecting the battery. Don't know if it's normal but at least it's nice to have company!!
That's pretty normal after clearing the computer. It will run a bit unusually until the computer relearns everything which happens as it is driven.
__________________
When you have a choice, buy American.

Jerry Bransford is online now   Quote Quick Reply
Old 12-21-2010, 02:43 PM   #16
Jeeper
 
Jon M's Avatar
 
Join Date: Aug 2010
Location: Deland, FL
Posts: 406
Thanks all for your input and help. Learning as I go and annoying the crap out of the wife who told me to get allthis done in the shop in the first place... But I think its a learning experience doing it myself.

__________________
'02 TJ Sport, Dana 44, 5spd, 31" GY DuraTrac's, Spiderweb Shadecage, Zone 2" BB w/Quick Discos
Jon M is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light the old guy TJ Tech Forum 3 11-25-2010 02:41 PM
Check Engine Light? Dewry636 TJ Tech Forum 0 10-29-2010 04:31 PM
Check Engine light - lean/rich JLS TJ Tech Forum 12 03-11-2010 12:09 AM
check engine light? NEED HELP shorty8914446 TJ Tech Forum 4 03-08-2010 04:26 PM
Check engine light when putting in new gauges Jon Neely YJ Tech Forum 4 10-06-2009 01:56 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:54 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC