spedo problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-20-2013, 03:17 AM   #1
Jeeper
 
Join Date: May 2011
Location: vancouver,wa
Posts: 32
spedo problems

ok so last week i threw my rear driveline on the freeway. well i fixed the driveline but now my spedo is going crazy its jumping from 30 to 100 without driving more than 20 i dont know what could have been messsed up anyone have any ideas ? i mean i threw my driveline and it droped right out didnt bang around or anything ? im lost

__________________
----------------------
98 2.5, 4.0 throttle body, air-intake,8.8 rear axle,36in swammpers, 2 1/2 coils, DIY high fender kit
TJCOUNTRYBOY is offline   Quote
Old 04-20-2013, 03:28 AM   #2
That WF guy.

WF Supporting Member
::WF Administrator::
 
distortedtj's Avatar
 
Join Date: May 2005
Location: yep right there.
Posts: 21,431
Send a message via Yahoo to distortedtj
Pull the speedo gear out and check the teeth on it. Also check the speedo drive gear in the tailhousing of the output shaft case of the tcase. When you pull the speedo gear you should be able to look into the hole and see it.
distortedtj is online now   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:08 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC