speedo / odometer problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-13-2010, 11:28 PM   #1
Newb
 
BigCrow74's Avatar
 
Join Date: Mar 2010
Posts: 8
speedo / odometer problems

I had a lift and SYE installed over the weekend. I picked it up from the shop and i noticed that the speedo and odometer werent registering. I looked underneath at the T-case and the speedo plug was plugged in. What could be the problem?? Its a 99 TJ, auto tranny, 231 t-case...I called the shop and told them. I cant get it back to them until Monday. I'd like to get an idea before they tell me something....thanks

BigCrow74 is offline   Quote Quick Reply
Old 04-14-2010, 12:52 AM   #2
Jeeper
 
jdhallissey's Avatar
 
Join Date: Aug 2008
Location: Gurnee,IL
Posts: 5,104
Send a message via AIM to jdhallissey
They probably didn't put the gear in correct when they put it all back together. So it might need a new gear or the old one taken out and spun a little to get it to mesh correctly.

__________________
Know nothing SPEAK on everything

Quote:
Originally Posted by ccain View Post
Isn't the JK just a rebodied PT Cruiser?!

Quote:
Originally Posted by coyote_94yj
Just a few more inches Red. You can take it.


If you haven't gotten more out of the insurance company than you deserve, then you haven't screwed them nearly as much as they have been screwing you for the past xx years.
jdhallissey is offline   Quote Quick Reply
Old 04-14-2010, 01:31 AM   #3
Jeeper
 
csamn2007's Avatar
 
Join Date: Aug 2009
Location: Peterson AFB CO
Posts: 1,911
Send a message via AIM to csamn2007
I would take it back to the shop and have them figure it out.
__________________
2000 Wrangler Sport
2 in Procomp SL 1 in BL
33 in Procomp MTs
csamn2007 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to fix all vacume problems and how to locate the problems. Captaincoop1220 YJ Tech Forum 50 02-23-2013 12:19 PM
Speedo Gear Spazzychaz TJ Tech Forum 8 07-09-2009 07:11 PM
Speedo gear: Issue semi resolved!!! Timberman TJ Tech Forum 0 02-26-2009 08:33 PM
speedo mrbigjeep TJ Tech Forum 17 08-10-2006 10:07 AM



» Featured Product

All times are GMT -5. The time now is 01:43 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC