Speedometer says I'm doing 100 all the time! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-03-2013, 07:51 AM   #1
Jeeper
 
Lowrollin12's Avatar
 
Join Date: Mar 2010
Location: Upstate New York
Posts: 340
Speedometer says I'm doing 100 all the time!

So I am at a loss here. All of a sudden my speedometer says I am always doing 100+ and I keep hitting the "limiter"

I replaced the spedo sensor and I am still having the issues.

I also realized my brake lights aren't working either so I am not sure if I had a surge that screwed something up.

Ugh Jeeps.....

__________________
MY 3rd TJ and favorite '03 Rubi with 3.5 Rock Krawler Short Arm Kit and RRD 2.0 Shocks, 32' Goodyear MTR's on Dick Cepek Wheels. Viar 450, CB and custom tool/Sub box.

Other rides: 95 Sonoma fully shaved, helium bags/rods for hoppin around, streetbeat rag top, SSBC bigbrake kit.... MORE $$$$ 04 Kawi Ninja zx-6 636 Blazin Orange!
Lowrollin12 is offline   Quote
Old 12-03-2013, 08:14 AM   #2
Jeeper
 
bryanpmorgan's Avatar
 
Join Date: May 2013
Location: Kane, PA
Posts: 23
try unplugging the tail light harness from the row of connectors under the dash. if you still have same problem you know the problem isn't the tail light harness. it would be somewhere up in the dash most likely. if the problem goes away its in the tail light wireing somewhere which is pretty easy to follow.

bryanpmorgan is offline   Quote
Old 12-09-2013, 06:02 PM   #3
Jeeper
 
Lowrollin12's Avatar
 
Join Date: Mar 2010
Location: Upstate New York
Posts: 340
Really no help here? I can't believe this hasn't happened to anyone else on this forum.

Anyways, I replaced the brake petal switch and that wasn't it either. So I have some type of issue that has screwed up my Jeep. Speedometer is way off and no brake lights. (all running lights and turn signals work)

Any help on this would be appreciated, I have been tinkering with this for the last week and haven't gotten ANYWHERE! PLEASE HELP!
__________________
MY 3rd TJ and favorite '03 Rubi with 3.5 Rock Krawler Short Arm Kit and RRD 2.0 Shocks, 32' Goodyear MTR's on Dick Cepek Wheels. Viar 450, CB and custom tool/Sub box.

Other rides: 95 Sonoma fully shaved, helium bags/rods for hoppin around, streetbeat rag top, SSBC bigbrake kit.... MORE $$$$ 04 Kawi Ninja zx-6 636 Blazin Orange!
Lowrollin12 is offline   Quote
Old 12-09-2013, 08:31 PM   #4
Jeeper
 
1Felix1's Avatar
 
Join Date: Sep 2013
Posts: 34
just a shot in the night but have you checked your battery??
1Felix1 is offline   Quote
Old 12-10-2013, 11:12 AM   #5
Supporting Member

WF Supporting Member
 
jeepwayoflife's Avatar
 
Join Date: Nov 2011
Location: California/Montana
Posts: 3,190
Check all fuses and ground leads for the brake lights. Are you sure both lights are good? Speedometer gear in good shape and tightly screwed in?
__________________
--------------------------------------------------------
jeepwayoflife is offline   Quote
Old 12-11-2013, 01:31 PM   #6
Jeeper
 
Lowrollin12's Avatar
 
Join Date: Mar 2010
Location: Upstate New York
Posts: 340
Not sure what about the battery I am checking but I have checked all fuses and they use the same ground for running and directional so they are fine.

I think I may have a burnt capacitor in the gauge cluster but not sure what that would have to do with my brake light signal.

__________________
MY 3rd TJ and favorite '03 Rubi with 3.5 Rock Krawler Short Arm Kit and RRD 2.0 Shocks, 32' Goodyear MTR's on Dick Cepek Wheels. Viar 450, CB and custom tool/Sub box.

Other rides: 95 Sonoma fully shaved, helium bags/rods for hoppin around, streetbeat rag top, SSBC bigbrake kit.... MORE $$$$ 04 Kawi Ninja zx-6 636 Blazin Orange!
Lowrollin12 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:48 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC