Sputtering and RPM's drop and raise at a stop - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-21-2013, 07:31 PM   #1
Jeeper
 
MIVLIFE's Avatar
 
Join Date: Jul 2012
Location: Kissimmee/St.Cloud Florida
Posts: 92
Sputtering and RPM's drop and raise at a stop

I was driving my TJ today and it sputtered as i was driving(its manual),then when i came to a red light,the rpm started just movin up and down. I continued to ride, at the nxt traffic light it repeated the rpm's but then it just shut off on me while i had it on nuetral. Can someone help me????

MIVLIFE is offline   Quote Quick Reply
Old 06-21-2013, 07:45 PM   #2
Jeeper
 
Join Date: Jan 2013
Location: Appleton, WI
Posts: 534
Send a message via Yahoo to ChaddG
Please tell what year and model of wrangler you have
It could be many things depending on your year

ChaddG is offline   Quote Quick Reply
Old 06-21-2013, 07:47 PM   #3
Jeeper
 
Join Date: Jan 2013
Location: Appleton, WI
Posts: 534
Send a message via Yahoo to ChaddG
I just read 28 things It could be in the haynes
ChaddG is offline   Quote Quick Reply
Old 06-21-2013, 07:49 PM   #4
Jeeper
 
MIVLIFE's Avatar
 
Join Date: Jul 2012
Location: Kissimmee/St.Cloud Florida
Posts: 92
1998
MIVLIFE is offline   Quote Quick Reply
Old 06-21-2013, 07:51 PM   #5
Jeeper
 
MIVLIFE's Avatar
 
Join Date: Jul 2012
Location: Kissimmee/St.Cloud Florida
Posts: 92
Quote:
Originally Posted by ChaddG View Post
I just read 28 things It could be in the haynes
98 sport 2.5
MIVLIFE is offline   Quote Quick Reply
Old 06-21-2013, 08:02 PM   #6
Jeeper
 
Join Date: Jan 2013
Location: Appleton, WI
Posts: 534
Send a message via Yahoo to ChaddG
section 8 troubleshooting. engine "lopes " while idling or idles erratically

vacuum leak.
intake manifold bolts
leaking egr valve or plugged pcv valve
air filter clogged
fuel pump not delivering enough fuel
leaking head gasket
timing chain worn
camshaft lobes worn
valves burned or leaking
ignition timin out of adjustment
ignition system not operating properly
dirty or clogged injectors/ carb dirty clogged or out of adjustment
idle speed ot of adjustment

Section 9 engine misses at idle speed.
spark plugs faulty or not gapped properly
faulty spark plug wires
wet or damaged distributor components
short circuits in ignition, coil or spark plug wires
sticking or faulty emissions system
clogged fuel filter<--in tank strainer only 14.00 at parts store if it has never been changed, I would drain your tank and start there.
vacuum leaks at intake manifold or hose connections
incorrect idle speed or idle mixture
incorrect timing
low or uneven cylinder compression
choke not operating properly
clogged or dirty fuel injectors
ChaddG is offline   Quote Quick Reply
Old 06-21-2013, 08:05 PM   #7
Jeeper
 
MIVLIFE's Avatar
 
Join Date: Jul 2012
Location: Kissimmee/St.Cloud Florida
Posts: 92
Wow.. Interesting. i got my hands full. grrrrrrr....
MIVLIFE is offline   Quote Quick Reply
Old 06-21-2013, 08:06 PM   #8
Jeeper
 
MIVLIFE's Avatar
 
Join Date: Jul 2012
Location: Kissimmee/St.Cloud Florida
Posts: 92
Thanks for the repsonse,and the help
MIVLIFE is offline   Quote Quick Reply
Old 06-21-2013, 08:06 PM   #9
Jeeper
 
Join Date: Jan 2013
Location: Appleton, WI
Posts: 534
Send a message via Yahoo to ChaddG
check the easy stuff first
then move to the harder more expensive. sometimes it is something simple
clean your throttle plate on your intake manifold. Take it off and spray it with carb and choke cleaner
take your pcv valve out and see if it rattles, if so its good.
check your air filter, plugs and wires.
make sure they are good.
do you have a distributer? check that its not all fouled up. take it off and use a bit of super fine sandpaper to clean the black stuff off from the inside, or buy a new one.
if you don't have a distributer, change your plugs, <gap them right> and replace your spark rail that holds them in. 99.00 at parts store.
start there. if you still have issues, check into your fuel filter, <in tank strainer> run your gas out and change that. carefully. you need to pull the sending unit. It's not very tough. just takes time and patience.
ChaddG is offline   Quote Quick Reply
Old 06-21-2013, 08:07 PM   #10
Jeeper
 
Join Date: Jan 2013
Location: Appleton, WI
Posts: 534
Send a message via Yahoo to ChaddG
all this checking stuff should only take you an hour or so
like I said start with the easy stuff
ChaddG is offline   Quote Quick Reply
Old 06-21-2013, 08:16 PM   #11
Jeeper
 
MIVLIFE's Avatar
 
Join Date: Jul 2012
Location: Kissimmee/St.Cloud Florida
Posts: 92
I have a job to do tomorrow..... Ill come back on and let u know if i got it running right.
Thanks Chadd
MIVLIFE is offline   Quote Quick Reply
Old 06-22-2013, 01:02 PM   #12
Jeeper
 
jherrington's Avatar
 
Join Date: Jan 2012
Location: Baton Rouge
Posts: 1,991
First off, before you go digging into everything.. If you're sitting still, and you hold the gas it runs just fine right? It's only at idle? Then it's most likely your idle air control valve. It's attached and behind to where your air tube housing meets the intake.

Edit: so, it happens when your driving too. Well, if it happens when your foot isn't on the gas, I'm sure it's your IAC.
__________________
98 TJ sport 4.0L I6 356,000 miles.
No Engine, axle, tranny, or t-case rebuilds.
Check out my 5.3 swap in progress here!
jherrington is offline   Quote Quick Reply
Old 06-27-2013, 05:18 PM   #13
Jeeper
 
MIVLIFE's Avatar
 
Join Date: Jul 2012
Location: Kissimmee/St.Cloud Florida
Posts: 92
I wanna thank the brothers that had some imput,on helping solve my issues. Glad to announce that i was able to fix it. It took literally 10min. It was the TPS- throttle position sensor.
MIVLIFE is offline   Quote Quick Reply
Old 06-27-2013, 05:21 PM   #14
Jeeper
 
Owen_TJ's Avatar
 
Join Date: Sep 2010
Location: Denver, CO
Posts: 3,753
Was just about to post for you

mine is currently doing the exact same thing...i have to also replace my injectors due to a bad cylinder 2 injector but yeah, i'll be replacing my tps/iac/throttle body/and injectors tonight
Owen_TJ is offline   Quote Quick Reply
Old 06-27-2013, 07:00 PM   #15
Jeeper
 
jherrington's Avatar
 
Join Date: Jan 2012
Location: Baton Rouge
Posts: 1,991
Quote:
Originally Posted by MIVLIFE View Post
I wanna thank the brothers that had some imput,on helping solve my issues. Glad to announce that i was able to fix it. It took literally 10min. It was the TPS- throttle position sensor.
That and the IAC are usually it!

__________________
98 TJ sport 4.0L I6 356,000 miles.
No Engine, axle, tranny, or t-case rebuilds.
Check out my 5.3 swap in progress here!
jherrington is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:24 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC