Sputters at high speed and no cruise control - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-30-2012, 10:13 AM   #1
Jeeper
 
asouza's Avatar
 
Join Date: Oct 2012
Location: Chico
Posts: 46
Sputters at high speed and no cruise control

This is my second TJ and I have been testing her limits since I picked her up. Last week I had to do a stream crossing in about 3' of water. Half way through she stuttered a bit and was afraid I was going to stall, but got through. No apparent long term issues from that. The other day I took her out on a pretty wet and muddy jeep trail for work and rode her pretty hard and aggressive. Back on the highway she started sputtering at around 60+ mph, and the cruise control would cut off when it started sputtering. Now a few days later the cruise control doesn't work at all, and she is still sputtering at the higher speeds, on acceleration. When I reach speed she rides fine and is fine at idle. Checked the distributor and plugs for moisture but are dry. Any suggestions?

asouza is offline   Quote
Old 11-30-2012, 10:25 AM   #2
Jeeper
 
02 TJ's Avatar
 
Join Date: Sep 2012
Location: Ridgefield, WA
Posts: 109
My guess would be a vacuum leak maybe you ripped off a hose some where.
02 TJ is offline   Quote
Reply

Tags
cruise control , rough running , sputter

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:21 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC