Squeaking noise in rear - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-30-2013, 07:41 AM   #1
Jeeper
 
Join Date: Dec 2011
Posts: 121
Squeaking noise in rear

Looking for ideas or suggestions on what to check....

I've developed a random squeak somewhere in the rear of my 04 Rubi. It started a few weeks after I had a 2.5" OME kit installed back in early March. It seems to happen when I hit any little bump in the road or turn.

My initial thoughts were: 1) loose rear track bar, or 2) rear sway bar. The track bar, including relocation bracket, seems to be tight. The rear sway bar is a different story, but I'm not 100% sure which components of the rear sway bar system should OR shouldn't have play. I can basically grab the sway bar and slide it a 1/4" side to side. Is this normal? It looks like the movement is caused by the top mount being loose or worn.

vwlos is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:49 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC