Sticky Voltmeter? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-18-2013, 05:53 PM   #1
Jeeper
 
CountryBoyJeep's Avatar
 
Join Date: Jul 2012
Posts: 561
Question Sticky Voltmeter?

A few days ago I was driving and notice mid trip my voltmeter was all the way down. Now when I start my Jeep the volt meter reads at about 10 volts yet still runs fine. After about 10 seconds it goes right back up to 14 volts. My alternator is still putting out power and my battery is fine from what I can tell. I think my voltmeter is off or sticking. Any thoughts?

CountryBoyJeep is offline   Quote
Old 03-18-2013, 09:19 PM   #2
Jeeper
 
CountryBoyJeep's Avatar
 
Join Date: Jul 2012
Posts: 561
Guess no Jeepers can solve this one.

CountryBoyJeep is offline   Quote
Old 03-18-2013, 09:43 PM   #3
Jeeper
 
mpbannon60's Avatar
 
Join Date: Jun 2011
Location: boothwyn pa
Posts: 106
Check the connections on the guage
mpbannon60 is offline   Quote
Old 03-18-2013, 09:43 PM   #4
Jeeper
 
mpbannon60's Avatar
 
Join Date: Jun 2011
Location: boothwyn pa
Posts: 106
And alternator
mpbannon60 is offline   Quote
Old 03-19-2013, 12:14 AM   #5
Jeeper
 
jeepsrgreat's Avatar
 
Join Date: Aug 2012
Posts: 312
I had this just last week. Mime was just some dirty battery terminals. Had me worried for a bit.
__________________
Jeeps are like Lego: Make it any way you want it, break it and start over again.
jeepsrgreat is offline   Quote
Old 03-19-2013, 08:42 AM   #6
Jeeper
 
CountryBoyJeep's Avatar
 
Join Date: Jul 2012
Posts: 561
Quote:
Originally Posted by jeepsrgreat View Post
I had this just last week. Mime was just some dirty battery terminals. Had me worried for a bit.
I actually just ceaned my battery terminals after. It wasn't on purpose but It didn't help
CountryBoyJeep is offline   Quote
Old 03-19-2013, 09:36 AM   #7
Jeeper
 
mpbannon60's Avatar
 
Join Date: Jun 2011
Location: boothwyn pa
Posts: 106
Along with the ones on the alternator?
mpbannon60 is offline   Quote
Old 03-19-2013, 03:22 PM   #8
Jeeper
 
CountryBoyJeep's Avatar
 
Join Date: Jul 2012
Posts: 561
I can do the alternator ones but that wouldn't explain it
CountryBoyJeep is offline   Quote
Old 03-22-2013, 05:20 PM   #9
Jeeper
 
mpbannon60's Avatar
 
Join Date: Jun 2011
Location: boothwyn pa
Posts: 106
Ever fix this problem?
mpbannon60 is offline   Quote
Old 03-22-2013, 08:11 PM   #10
Jeeper
 
CountryBoyJeep's Avatar
 
Join Date: Jul 2012
Posts: 561
No I have not fully fixed it but the problem is easing with time

CountryBoyJeep is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:02 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC