Sticky Voltmeter? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-18-2013, 06:53 PM   #1
Jeeper
 
CountryBoyJeep's Avatar
 
Join Date: Jul 2012
Posts: 515
Question Sticky Voltmeter?

A few days ago I was driving and notice mid trip my voltmeter was all the way down. Now when I start my Jeep the volt meter reads at about 10 volts yet still runs fine. After about 10 seconds it goes right back up to 14 volts. My alternator is still putting out power and my battery is fine from what I can tell. I think my voltmeter is off or sticking. Any thoughts?

CountryBoyJeep is offline   Quote Quick Reply
Old 03-18-2013, 10:19 PM   #2
Jeeper
 
CountryBoyJeep's Avatar
 
Join Date: Jul 2012
Posts: 515
Guess no Jeepers can solve this one.

CountryBoyJeep is offline   Quote Quick Reply
Old 03-18-2013, 10:43 PM   #3
Jeeper
 
mpbannon60's Avatar
 
Join Date: Jun 2011
Location: boothwyn pa
Posts: 101
Check the connections on the guage
mpbannon60 is offline   Quote Quick Reply
Old 03-18-2013, 10:43 PM   #4
Jeeper
 
mpbannon60's Avatar
 
Join Date: Jun 2011
Location: boothwyn pa
Posts: 101
And alternator
mpbannon60 is offline   Quote Quick Reply
Old 03-19-2013, 01:14 AM   #5
Jeeper
 
jeepsrgreat's Avatar
 
Join Date: Aug 2012
Posts: 312
I had this just last week. Mime was just some dirty battery terminals. Had me worried for a bit.
__________________
Jeeps are like Lego: Make it any way you want it, break it and start over again.
jeepsrgreat is offline   Quote Quick Reply
Old 03-19-2013, 09:42 AM   #6
Jeeper
 
CountryBoyJeep's Avatar
 
Join Date: Jul 2012
Posts: 515
Quote:
Originally Posted by jeepsrgreat View Post
I had this just last week. Mime was just some dirty battery terminals. Had me worried for a bit.
I actually just ceaned my battery terminals after. It wasn't on purpose but It didn't help
CountryBoyJeep is offline   Quote Quick Reply
Old 03-19-2013, 10:36 AM   #7
Jeeper
 
mpbannon60's Avatar
 
Join Date: Jun 2011
Location: boothwyn pa
Posts: 101
Along with the ones on the alternator?
mpbannon60 is offline   Quote Quick Reply
Old 03-19-2013, 04:22 PM   #8
Jeeper
 
CountryBoyJeep's Avatar
 
Join Date: Jul 2012
Posts: 515
I can do the alternator ones but that wouldn't explain it
CountryBoyJeep is offline   Quote Quick Reply
Old 03-22-2013, 06:20 PM   #9
Jeeper
 
mpbannon60's Avatar
 
Join Date: Jun 2011
Location: boothwyn pa
Posts: 101
Ever fix this problem?
mpbannon60 is offline   Quote Quick Reply
Old 03-22-2013, 09:11 PM   #10
Jeeper
 
CountryBoyJeep's Avatar
 
Join Date: Jul 2012
Posts: 515
No I have not fully fixed it but the problem is easing with time

CountryBoyJeep is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:39 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC