Strange noise: whistle/whining sound - Page 2 - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today



Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-11-2017, 02:01 AM   #31
Jeeper
 
B.F.J.'s Avatar
 
Join Date: Sep 2012
Posts: 27
B.F.J. is on a distinguished road
I started getting a whistle sound this winter. it occurs when I start the car and step on the break to shift to Drive. At first I thought it was the act of shifting to Drive, but just today, it lasted longer for a minute after i started driving. The whistle sound would happen when I pressed down on the break. It only happened for the first minute maybe while the engine was still cool? The sound was not cyclical like a belt or breaks. It was definitely a whistle - a high pitch sound coming from the engine...

Any ideas?
B.F.J. is offline   Quote
Old 01-11-2017, 07:41 PM   #32
Jeeper
 
CzerOne's Avatar
 
Join Date: Feb 2016
Location: Bedford, NS
Posts: 403
CzerOne is on a distinguished road
My Jeep started doing this when the cold weather started too. Only when throttle plate is closed or almost closed. Haven't gotten around to checking it yet; haven't had the time. It sounds like an Intake leak or the whistle you get from an open filter air Intake at partial throttle.


Sent from my iPhone using Tapatalk

__________________
2003 TJ Sport
BDS|WARN|JKS|MOTIVE|COOPER|PROCOMP|BESTOP|TERAFLEX |SMITTYBILT|TOMWOODS|G2|RUGGEDRIDGE
CzerOne is offline   Quote
Old 01-18-2017, 01:05 PM   #33
Newb
 
Join Date: Sep 2016
Location: Atlanta, GA
Posts: 1
zaiid138 is on a distinguished road
for me, it was the Thermostat.. the whistle would get louder the more the car warmed up on cold days.. when it got really cold, the CEL came on.. the CEL was for the thermostat.. i took off the thermostat housing and noticed the Thermostat housing was corroded additionally it had an tremendous amount of TRV.. ended up changing the Thermostat Housing, Thermostat, upper radiator hose, Coolant Temperature sensor... and while i was there.. decided to do the Water Pump as well (no telling when it was last changed).. so for the water pump i installed a new Waterpump, waterpump gasket, waterpump inlet tube.. easy job.. toughest part was cleaning off old RTV and old gasket

zaiid138 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:47 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC
« Back

Enter your email address:

Delivered by FeedBurner