Subwoofer not Working - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-08-2013, 10:24 PM   #1
Jeeper
 
l. fopps's Avatar
 
Join Date: Nov 2013
Location: Old Bridge NJ
Posts: 54
Subwoofer not Working

New to me TJ. Subwoofer is not working. I checked the fuse in spot 3, its good. Just checked all wiring to the head unit and the blue wires are connected and everything else wiring at the head unit wise is good. What would be some other things to check? I haven't pulled off the console yet, going to do that this week hopefully. Also where is the amp located?

l. fopps is offline   Quote Quick Reply
Old 12-08-2013, 10:45 PM   #2
Jeeper
 
Join Date: Aug 2008
Location: Fleetwood, PA
Posts: 146
Could also be that the speaker is blown. No offense but the stock speakers they put in most vehicles are cheap and are usually paper cones.

GGA1759 is offline   Quote Quick Reply
Old 12-08-2013, 10:54 PM   #3
Jeeper
 
l. fopps's Avatar
 
Join Date: Nov 2013
Location: Old Bridge NJ
Posts: 54
Yeah im gonna pull the console this week one night after work and check that out. I don't think its the stock sub based on the visible markings on it through the grille, but who knows maybe this is blown also. Do you know where the amp is located? assuming under the console as well? wanna get the multi meter on it.
l. fopps is offline   Quote Quick Reply
Old 12-08-2013, 10:57 PM   #4
Jeeper
 
SSMILLER67's Avatar
 
Join Date: Nov 2013
Posts: 16
Yep. It's in the console.
SSMILLER67 is offline   Quote Quick Reply
Old 12-09-2013, 06:20 AM   #5
Jeeper
 
BigCrave's Avatar
 
Join Date: Dec 2012
Location: TN
Posts: 275
It's built into the sub housing under the console.
BigCrave is offline   Quote Quick Reply
Old 12-09-2013, 09:41 AM   #6
Jeeper
 
Parsonsm's Avatar
 
Join Date: Feb 2013
Location: Daytona Beach
Posts: 211
I had a similar problem after installing a replacement sub and it turned out being a loose ground wire under the steering column.
Parsonsm is offline   Quote Quick Reply
Old 12-09-2013, 10:07 AM   #7
Jeeper
 
idiot magnet's Avatar
 
Join Date: Oct 2009
Location: Noblesville, IN
Posts: 531
Mine stopped working and it ended up being a loose wire at the sub itself.
idiot magnet is offline   Quote Quick Reply
Old 12-09-2013, 02:48 PM   #8
Jeeper
 
l. fopps's Avatar
 
Join Date: Nov 2013
Location: Old Bridge NJ
Posts: 54
Quote:
Originally Posted by Parsonsm View Post
I had a similar problem after installing a replacement sub and it turned out being a loose ground wire under the steering column.
Quote:
Originally Posted by idiot magnet View Post
Mine stopped working and it ended up being a loose wire at the sub itself.
Going to check both of these out. I'm thinking the loose wire at the sub is possible. I thought it was working when i first bought the jeep 2 weeks ago, and the entire center console is loose and i was shaking it back and forth the first day. Its possible it came loose from that. At some point this week i'll look into it. Thanks for all the suggestions.
l. fopps is offline   Quote Quick Reply
Old 12-12-2013, 12:33 PM   #9
Jeeper
 
asnyder's Avatar
 
Join Date: Aug 2013
Posts: 37
Trace the subs wires and you'll find the amp. My amp is a little old and the wires were going bad so I replaced the ground wire and it's all good now.
asnyder is offline   Quote Quick Reply
Old 12-12-2013, 09:34 PM   #10
Jeeper
 
Mountainman12's Avatar
 
Join Date: Dec 2013
Location: dallas tx
Posts: 184
Click image for larger version

Name:	image-2688259858.jpg
Views:	55
Size:	174.2 KB
ID:	586425

Mine stopped working but in my opinion not worth fixing I would by this boss rs80 mount it under seat ad you can feel the base and it sounds great..

Mountainman12 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:42 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC