Temperature Problem - Better Radiator ? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-26-2008, 05:46 AM   #1
Jeeper
 
nicolas-eric's Avatar
 
Join Date: Jan 2007
Location: Hamburg, Germany
Posts: 5,877
Send a message via ICQ to nicolas-eric Send a message via AIM to nicolas-eric Send a message via MSN to nicolas-eric Send a message via Yahoo to nicolas-eric
Temperature Problem - Better Radiator ?

Hello.

I tried to clean my stock radiator but Iīve still a small overheating problem.

A friend told me that a radiator should be strong enough to cool the engine at speeds +45 mph without the fan.
At this speed my engine temperature was at about 210 F when my TJ was new. Now itīs at about 220 F. Is that too hot? Or is it still ok?

I thought sbout installing a better radiator to fix this problem. Which radiator offers a better cooling and fits into my 06 TJ 4.0L with A/C? I also have an auto tranny cooler in the stock radiator.

btw which operating temperature does the stock thermostat have?

Thanks!
nicolas-eric

nicolas-eric is offline   Quote Quick Reply
Old 08-26-2008, 01:47 PM   #2
Jeeper
 
jtraider's Avatar
 
Join Date: Feb 2008
Location: skiatook(yes, the sticks), ok
Posts: 165
What year? i had over heating problems with my 98. i tried everything. when i finally got to the water pump, there wasn't much left of the fanblades. changed it out and haven't had a problem since.

jtraider is offline   Quote Quick Reply
Old 08-26-2008, 01:58 PM   #3
Jeeper
 
nicolas-eric's Avatar
 
Join Date: Jan 2007
Location: Hamburg, Germany
Posts: 5,877
Send a message via ICQ to nicolas-eric Send a message via AIM to nicolas-eric Send a message via MSN to nicolas-eric Send a message via Yahoo to nicolas-eric
itīs a 2006 TJ with only 13.000 miles.
nicolas-eric is offline   Quote Quick Reply
Old 08-26-2008, 02:09 PM   #4
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,381
Images: 2
The factory specified thermostat temp is 195 degrees. 210 degrees is normal but 220 on a hot day is not unusual.

An all aluminum radiator is the best at cooling but the OE radiator's core is already all aluminum. If your temperature continues to run unusually hot however, your radiator might be starting to clog up with hard water deposits if you use tap water in it. To keep a radiator free of deposits, only distilled water should be used. So if it is starting to clog with hard water deposits (which you can often see by looking through the radiator cap opening ), it would have to be replaced since the OE radiator cannot be cleaned of those deposits like an aftermarket radiator can.
__________________
When you have a choice, buy American.

Jerry Bransford is online now   Quote Quick Reply
Old 08-26-2008, 02:19 PM   #5
Jeeper
 
Join Date: Aug 2007
Posts: 78
overheating

Quote:
Originally Posted by nicolas-eric View Post
itīs a 2006 TJ with only 13.000 miles.
x2 on the 195 degree stat. 210 is normal operating temp and like Jerry says "220 isn't unusal. Are you familiar with doing the fan clutch test? with 13k on the engine, are you still runnin original coolant? If ever lost any you would want to use 50/50 blend of coolant.
AzTrailRunner is offline   Quote Quick Reply
Old 08-26-2008, 02:23 PM   #6
Jeeper
 
nicolas-eric's Avatar
 
Join Date: Jan 2007
Location: Hamburg, Germany
Posts: 5,877
Send a message via ICQ to nicolas-eric Send a message via AIM to nicolas-eric Send a message via MSN to nicolas-eric Send a message via Yahoo to nicolas-eric
220 F isnīt unusual? I thought that wouldīt be good for the engine..

I still have the cooling water that was filled in from jeep in the factory. IMO it should be destilled water.

Is there an affordable all-aluminum radiator on the market that fits in my 06 TJ with auto tranny?
Whatīs about this one: 4Wheel Drive Hardware Aluminum Radiator and Other Jeep Parts and Jeep Accessories by 4 Wheel Drive Hardware

A friend told me that "Be Cool" radiators are very good. But I canīt find a radiator, that fits into my TJ.


BTW i think that mud causes my problem. I already cleaned the radiator, but thereīs still too much between the radiator fins.

Before:



After:

nicolas-eric is offline   Quote Quick Reply
Old 08-26-2008, 02:26 PM   #7
Jeeper
 
nicolas-eric's Avatar
 
Join Date: Jan 2007
Location: Hamburg, Germany
Posts: 5,877
Send a message via ICQ to nicolas-eric Send a message via AIM to nicolas-eric Send a message via MSN to nicolas-eric Send a message via Yahoo to nicolas-eric
Oh sorry, I forgot to say, that I have a flex-a-lite e-fan for about a week now. But I have the problem since the last time I was mudding.
The temperature is at 210 degrees now, but the fan runs all the time. When the fan is turned off the temperature goes up to 220-225 degrees. And the outside temperature is only 65-70 degrees.
nicolas-eric is offline   Quote Quick Reply
Old 08-26-2008, 02:28 PM   #8
Jeeper
 
Join Date: Aug 2007
Posts: 78
Quote:
Originally Posted by nicolas-eric View Post
220 F isnīt unusual? I thought that wouldīt be good for the engine..

I still have the cooling water that was filled in from jeep in the factory. IMO it should be destilled water.

Is there an affordable all-aluminum radiator on the market that fits in my 06 TJ with auto tranny?
Whatīs about this one: 4Wheel Drive Hardware Aluminum Radiator and Other Jeep Parts and Jeep Accessories by 4 Wheel Drive Hardware

A friend told me that "Be Cool" radiators are very good. But I canīt find a radiator, that fits into my TJ.


BTW i think that mud causes my problem. I already cleaned the radiator, but thereīs still too much between the radiator fins.

Before:



After:

Yep..your radiator needs a good cleaning. I'm sure it isn't getting the proper air flow. Do you have access to high pressure car wash? If not, remove it and clean it
AzTrailRunner is offline   Quote Quick Reply
Old 08-26-2008, 02:34 PM   #9
Jeeper
 
nicolas-eric's Avatar
 
Join Date: Jan 2007
Location: Hamburg, Germany
Posts: 5,877
Send a message via ICQ to nicolas-eric Send a message via AIM to nicolas-eric Send a message via MSN to nicolas-eric Send a message via Yahoo to nicolas-eric
Many people told me that a high-pressure washer will damage the radiator-fins.
I already cleaned it with the garden hose and a small high-pressure washer that my father uses to clean the terrace-
nicolas-eric is offline   Quote Quick Reply
Old 08-26-2008, 02:36 PM   #10
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,381
Images: 2
Your radiator's external cooling fins are probably packed with mud. As AzTrailRunner suggests, use a high pressure hose to clean them out. Just be careful.
__________________
When you have a choice, buy American.

Jerry Bransford is online now   Quote Quick Reply
Old 08-26-2008, 02:38 PM   #11
Jeeper
 
richp's Avatar
 
Join Date: Mar 2007
Location: Pocono mountains
Posts: 1,559
You gotta clean those fins, big time, if you have AC you also have to clean out the AC condenser and the space between the radiator and condenser. Thats pretty nasty in that pic. And get that fan shroud back on there.
I've never had ANY of my jeeps run over 210, on road or off road, except last saturday when I was towing a 5,000lb steel trailer with my 98XJ, with all my daughters stuff, she moved back home, from down in Philadelphia to here at 70mph uphill most of the 96 miles and it was 89F out.
I would even go so far as to drain the rad, pull it and use whatever brushes you need, then refill with a mix of 50/50 coolant and DISTILLED water. I'd also tend to replace the thermostat with the correct one from the dealer, the one with the weep/bleeder hole to get trapped air out.
richp is offline   Quote Quick Reply
Old 08-26-2008, 05:14 PM   #12
Jeeper
 
Join Date: Aug 2007
Posts: 78
fan shroud

Quote:
Originally Posted by richp View Post
You gotta clean those fins, big time, if you have AC you also have to clean out the AC condenser and the space between the radiator and condenser. Thats pretty nasty in that pic. And get that fan shroud back on there.
I've never had ANY of my jeeps run over 210, on road or off road, except last saturday when I was towing a 5,000lb steel trailer with my 98XJ, with all my daughters stuff, she moved back home, from down in Philadelphia to here at 70mph uphill most of the 96 miles and it was 89F out.
I would even go so far as to drain the rad, pull it and use whatever brushes you need, then refill with a mix of 50/50 coolant and DISTILLED water. I'd also tend to replace the thermostat with the correct one from the dealer, the one with the weep/bleeder hole to get trapped air out.

Good call on the fan shroud. Reminds of the saying, I can't see the forest because of the trees. I bet his temp lowers 5 degrees when he cleans his a/c condenser and his radiators fins. Any bets??
AzTrailRunner is offline   Quote Quick Reply
Old 08-26-2008, 05:27 PM   #13
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,381
Images: 2
Quote:
Originally Posted by richp View Post
And get that fan shroud back on there.
Holy smoke how'd I miss that?? Nicolas, you have to get that fan shroud reinstalled. Fan shrouds are extremely important to good cooling as they force the air to be pulled through the radiator instead of the fan just creating a lot of wild turbulant air in the engine compartment.
__________________
When you have a choice, buy American.

Jerry Bransford is online now   Quote Quick Reply
Old 08-26-2008, 06:51 PM   #14
Jeeper
 
nicolas-eric's Avatar
 
Join Date: Jan 2007
Location: Hamburg, Germany
Posts: 5,877
Send a message via ICQ to nicolas-eric Send a message via AIM to nicolas-eric Send a message via MSN to nicolas-eric Send a message via Yahoo to nicolas-eric
I wrote some posts before that i have an e-fan. The pics are from the day when i cleaned the radiator and installed the e-fan.

Cleaned radiators:



At the moment it looks like this. Itīs the Flex-A-Lite Wrangler Extreme Fan.

nicolas-eric is offline   Quote Quick Reply
Old 08-26-2008, 09:26 PM   #15
Jeeper
 
richp's Avatar
 
Join Date: Mar 2007
Location: Pocono mountains
Posts: 1,559
Probably going to start a war here but, everyone I know in my group of jeep friends that have gone to the dark side of electric fans has done one of two things, either admitted it sucked and switched back or did not admit it and quietly switched back to the stock fan clutch, fan and shroud. The only setup I have seen that works is two pusher fans on the front and two puller fans in the back and thats on a 92XJ that rarely sees the road and when it does it tends to run hot at hiway speeds, oh and he had to put a 180Amp alternator in it too.
richp is offline   Quote Quick Reply
Old 08-27-2008, 12:32 AM   #16
Jeeper
 
Rawkon's Avatar
 
Join Date: Apr 2005
Location: fullerton/big bear
Posts: 2,061
Send a message via AIM to Rawkon Send a message via MSN to Rawkon
Ever since i switched to an Efan Ive loved it. most guys dont take the time and have them properly setup which is why they switch back. if you look under most hoods nowaday in non HD vehicles you will find E fans everywhere. ever since i put in my flexalite just like Nico's i havnt had issues. the fan shroud is the key along with a high CFM rating. I was running hot at highway speeds too but it ended up being a bad T stat. running hot at highway speeds has nothing to do with a fan. I use to switch my fan off on the highways just to see how far i could go without getting hot. 3 fans is waaaaay to much. just have him get a good flexalite with a built in shroud like mine and nicos and thats all you need for a jeep. getting hot at highway speeds means air in the system, collapsing hoses, bad t stat, bad water pump, clogged radiator, clogged fins, sometimes a bad fan but at highway speed you really dont need too much of a fan.

Hey Nico, keep an eye out for your fan motor rubbing on the radiator. I had to space out my fan from the radiator to keep it from rubbing a hole in the rad
Rawkon is offline   Quote Quick Reply
Old 08-27-2008, 02:01 AM   #17
Jeeper
 
nicolas-eric's Avatar
 
Join Date: Jan 2007
Location: Hamburg, Germany
Posts: 5,877
Send a message via ICQ to nicolas-eric Send a message via AIM to nicolas-eric Send a message via MSN to nicolas-eric Send a message via Yahoo to nicolas-eric
The problem was there BEFORE I installed the e-fan.
nicolas-eric is offline   Quote Quick Reply
Old 09-07-2008, 07:32 PM   #18
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
How about you Nico have you figured your overheating problem out??? I am bumping this one and a thread by Rawkon about overheating to see if we can get some more answers.I am having a problem also.Mine only does it at highway speeds normally going up hills on the freeway or for long pulls in 4 lo.I have a new aluminum radiator and have done replaced the t-stat twice.This time with a 185 premium stat.
__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Old 09-07-2008, 07:41 PM   #19
Jeeper
 
nicolas-eric's Avatar
 
Join Date: Jan 2007
Location: Hamburg, Germany
Posts: 5,877
Send a message via ICQ to nicolas-eric Send a message via AIM to nicolas-eric Send a message via MSN to nicolas-eric Send a message via Yahoo to nicolas-eric
it is definately the radiator.
i was in a radiator shop and they checked the whole cooling system.

now with the e-fan the temperature is always at 210 degrees. but at speeds above 50 mph the fan runs all the time. in 2 weeks iīm in an offroad camp with very deep mud. after that weekend iīll install the new radiator.

a t-stat with a lower temperature doesnīt help if the radiator is the problem. it only takes a bit longer until the coolant becomes too hot.

the guy in the radiator shop told me that itīs better to replace the stock radiator more often than installing an expensive all-aluminum radiator. a dirty all-aluminum radiator is as bad as a dirty cheap stock radiator. he told me that the TJs cooling system is made for very high temperatures in the desert and that it isn't necessary to install another than the stock radiator.
nicolas-eric is offline   Quote Quick Reply
Old 09-07-2008, 08:13 PM   #20
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
Well I read Rawkon had a bad t-statThat is for sure not my problem.Also I replaced my stock rad with aluminum because I didn't like the plastic tanks.I have done enough research over the last few days to go with my next step.I will pull the water pump and see what it looks like.I am hoping that the impeller fins are gone.That would explain my whole deal.I started out with the e-fan and all was good for a couple of months running around 190 then I was pulling my trailer with the quad the day my radiator top blew apart after hitting 220.So then I put the aluminum radiator and a new 195 regular t-stat in and good for a couple weeks with no problems then while in Harland going up hill on one of the trails mine boiled over at 220 so we got to a point in the trail were I let mine set for an hour or so and it done fine the rest of the trail runs and then on the way home I hit a long mountain section of interstate were it hit 220 or more and boiled over again were I let it set on the road side for a while and got to the next town were i sprayed the radiator out and cleaned my air filter and it done fine the rest of the way home.Yesterday I replaced the t-stat with a 180 HD stat and today while on interstate it would get up around 220 again but never did boil over.What do you guys think????
__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Old 09-07-2008, 08:19 PM   #21
Jeeper
 
nicolas-eric's Avatar
 
Join Date: Jan 2007
Location: Hamburg, Germany
Posts: 5,877
Send a message via ICQ to nicolas-eric Send a message via AIM to nicolas-eric Send a message via MSN to nicolas-eric Send a message via Yahoo to nicolas-eric
with a low temperature t-stat it takes a bit longer until the coolant overheats.
but keep in mind that teh TJ engine is made to run at temperatures from 200-210 degrees. if you run it colder it will not work in an ideal way (fuel efficiency, pollution, ..).

i hope for you that it is the waterpump. when you rplace it, install a highflow pump, that will work better at lower RPMs (the e-fan will not turn on that often at idle p.e.). that only costs about 100$.
FlowKooler Automobile Water Pumps - Chevy, Dodge, Jeep, Ford, and more

which all-aluminum radiator did you install?
nicolas-eric is offline   Quote Quick Reply
Old 09-07-2008, 08:36 PM   #22
Jeeper
 
Rawkon's Avatar
 
Join Date: Apr 2005
Location: fullerton/big bear
Posts: 2,061
Send a message via AIM to Rawkon Send a message via MSN to Rawkon
i would give your system a pressure test on top of checking the water pump.
Rawkon is offline   Quote Quick Reply
Old 09-07-2008, 08:44 PM   #23
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
Already done that.It will hold at 18lb with no problems.But if I take it to 20lb it creaps back to 18 with no signs of coolant but stays at 18 as long as you leave the pump&guage attached it stays right there???I am going to replace the cap also cause it still has the rusty corrsion that the old radiator was full of caked in it around the rubber seals.I figured it was the old orange coolant but now am hopeing the rusty colored gunk is from the water pump.
__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Old 09-07-2008, 08:45 PM   #24
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
Yeah I know not to many times you hear someone say darn I hope my water pump is junk huh!!!!
__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Old 09-07-2008, 08:51 PM   #25
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
Here is a link to the radiator.And yes I have the factory shroud back on.It is on it right now and still didn't help.I have tried everything I can think of so if the water pump isn't the problem I am out of thing to try outside of the factory fan.I will try the fan first and see.If that doesn't work I will let ya know.then on the the pump.http://www.wranglerforum.com/f5/elec...-18939-12.html
__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Old 09-08-2008, 06:20 AM   #26
Jeeper
 
richp's Avatar
 
Join Date: Mar 2007
Location: Pocono mountains
Posts: 1,559
Quote:
Originally Posted by slf41002 View Post
Well I read Rawkon had a bad t-statThat is for sure not my problem.Also I replaced my stock rad with aluminum because I didn't like the plastic tanks.I have done enough research over the last few days to go with my next step.I will pull the water pump and see what it looks like.I am hoping that the impeller fins are gone.That would explain my whole deal.I started out with the e-fan and all was good for a couple of months running around 190 then I was pulling my trailer with the quad the day my radiator top blew apart after hitting 220.So then I put the aluminum radiator and a new 195 regular t-stat in and good for a couple weeks with no problems then while in Harland going up hill on one of the trails mine boiled over at 220 so we got to a point in the trail were I let mine set for an hour or so and it done fine the rest of the trail runs and then on the way home I hit a long mountain section of interstate were it hit 220 or more and boiled over again were I let it set on the road side for a while and got to the next town were i sprayed the radiator out and cleaned my air filter and it done fine the rest of the way home.Yesterday I replaced the t-stat with a 180 HD stat and today while on interstate it would get up around 220 again but never did boil over.What do you guys think????
Keep this in mind, ONE overheat of a brand new thermostat can turn the thermostat to toast.
richp is offline   Quote Quick Reply
Old 09-08-2008, 09:36 AM   #27
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
Yeah it has not really overheated like it did before the newest t-stat.Now it is just running way warmer than it should be around 220.It has not hit the point of boiling over like it did in Harland.It boiled over and the temp guage spiked/redlined.I think the temp spike was due to the fact once the coolant started out that gave way to steam that hit the temp sensor because the guage jumped straight from 220-230 to the red.I looked down and the guage was in the middle between 210 and 260 and a split second later it was on 260.Anyway it is now just running above the normal comfort zone.
__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Old 09-08-2008, 10:02 AM   #28
Jeeper
 
Rawkon's Avatar
 
Join Date: Apr 2005
Location: fullerton/big bear
Posts: 2,061
Send a message via AIM to Rawkon Send a message via MSN to Rawkon
SLF thats why i put in a autometer water gauge. and also put in a new temp sender in the stock location. its amazing how much my autometer fluctuates form 180 to 210 compared to the stock gauge which hit 210 and a little higher
Rawkon is offline   Quote Quick Reply
Old 09-08-2008, 04:47 PM   #29
Jeeper
 
slf41002's Avatar
 
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
Well now I am stumped!!! I pulled the water pump today and it is fine.I was hoping to find broken or rusted fins but it looks brand new.I am going to put a new one on anyway since I have this one off but other than the other items that I will have in the morning I do not know what else.I could not reuse the stock clutch fan to see if it made a difference due to the fact it either got bent,warped or the silicon in the clutch has settled cause it had real bad vibes with it back on.Anyway I will have the upper and lower hoses,new radiator cap,new belt plus the new water pump.Basically the whole coolant system will be new.If it still does it I will be lost.They will have to put in an extra slow lane on the interstate for me!!!!!!
__________________
I like for it to shine even thought it is muddy most of the time!
http://www.myspace.com/shermanf
slf41002 is offline   Quote Quick Reply
Old 09-08-2008, 06:35 PM   #30
Jeeper
 
richp's Avatar
 
Join Date: Mar 2007
Location: Pocono mountains
Posts: 1,559
Quote:
Originally Posted by slf41002 View Post
Well now I am stumped!!! I pulled the water pump today and it is fine.I was hoping to find broken or rusted fins but it looks brand new.I am going to put a new one on anyway since I have this one off but other than the other items that I will have in the morning I do not know what else.I could not reuse the stock clutch fan to see if it made a difference due to the fact it either got bent,warped or the silicon in the clutch has settled cause it had real bad vibes with it back on.Anyway I will have the upper and lower hoses,new radiator cap,new belt plus the new water pump.Basically the whole coolant system will be new.If it still does it I will be lost.They will have to put in an extra slow lane on the interstate for me!!!!!!
Out of curiosity, how did you check your belt tension ?

richp is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
Electric fan coversion slf41002 TJ Tech Forum 390 02-10-2013 07:32 PM
2400 miles on new jk having trans problem NTJeep JK Tech Forum 4 01-14-2009 01:03 AM
Which Replacement Radiator ? nicolas-eric TJ Tech Forum 0 09-02-2008 03:47 PM
Shifting Problem lonerider6 YJ Tech Forum 6 06-01-2008 03:51 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:33 PM.



JeepŪ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC