Temperature Unit Problems? Help? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-10-2013, 09:59 PM   #1
Jeeper
 
JeepMyth's Avatar
 
Join Date: Jul 2012
Location: Rockford Area/Dubuque IA
Posts: 185
Temperature Unit Problems? Help?

Hey guys thanks for checking out the thread, I really appreciate it. I'm having a problem with my temperature control unit below my radio. And keep in mind, some of this doesn't ALWAYS happen but it does happen.

1. The defrost setting doesn't do anything, all the blowers turn off. I know that the defrost thing could possibly work though because for a short moment after I switch the setting to feet and head blowers the defrost fan will also come on for a couple seconds.

2. The entire unit will just not work sometimes. As in I'll turn it to the any configuration of settings and nothing will happen.

3. When the unit is working all the speeds will work just fine, its just sometimes it doesn't work and sometimes some of the settings don't work as to where the heat goes. Mainly the defrost.

4.Normally in the early morning it'll work when I go to start my car for the morning, but usually when I come out to the parking lot after school it won't... Hmm. Any help would be totally appreciated!

JeepMyth is offline   Quote
Old 02-11-2013, 12:29 AM   #2
Jeeper
 
ohioviper's Avatar
 
Join Date: Sep 2012
Location: Chillicothe, Ohio
Posts: 2,757

__________________

2015 JKU
2013 JK
2000 TJ
ohioviper is offline   Quote
Old 02-11-2013, 06:16 AM   #3
Jeeper
 
Wattapunk's Avatar
 
Join Date: Mar 2012
Location: North TX
Posts: 2,349
Pull that switch and inspect the back for possibly corrosion or melting on the connections. Also look up behind the dash and inspect the vacuum actuators while you are changing the settings to defrost. The middle of those 3 actuators control the defrost.

Wattapunk is offline   Quote
Old 02-11-2013, 04:33 PM   #4
Jeeper
 
JeepMyth's Avatar
 
Join Date: Jul 2012
Location: Rockford Area/Dubuque IA
Posts: 185
Alright I'll take a look tonight! Thanks guys
JeepMyth is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 08:53 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC