Tranny problems... Now what?? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-21-2010, 10:01 PM   #1
Jeeper
 
at7190's Avatar
 
Join Date: Aug 2010
Posts: 26
Tranny problems... Now what??

So I have a 2006 TJ (auto trans) with 35k miles. About two weeks ago I started having transmission problems. It was knocking hard into gears when I first started driving it but then smoothing out after the first couple shifts. Took it to a couple places and ended up finding out I may be running hot. So I had my trans range sensor replaced trans flushed, filter replaced and codes cleared. It ran fine for about a day but then started acting up again after I drove on the highway for about an hour. So confirmed that I was running hot and got an aux cooler put in on Thursday. Decided to go up to Orlando for jeep/truck aftermarket parts show (2hrs away) to test out the new cooler. After the initial drive there it was fine but stopped off on the way home for about 15min and when I started back up of course it's knocking into gears again. Checked the trans fluid when I got home and it was well above hot. Now what? Anyone have ideas?

at7190 is offline   Quote Quick Reply
Old 08-21-2010, 10:41 PM   #2
Jeeper
 
pokey's Avatar
 
Join Date: Feb 2010
Location: backroads of the Mojave
Posts: 1,106
I'm not sure you can do more than the cooler, unless they make a larger one. Unfortunately that transmission has had problems overheating. I know they were used in the new JKs (maybe still are) and I believe there was a service bulletin addressing the problem. I believe the JK owners are getting the cooler installed for free.You may want to check with the dealer, you might have some recourse. Good luck.

__________________
__________________________________________
. . . . picking the lines with my twenty-nines . . . .
__________________________________________

'99 sport 4.0 5 speed, top-of-the-line floormats
pokey is offline   Quote Quick Reply
Old 08-23-2010, 05:28 PM   #3
Jeeper
 
at7190's Avatar
 
Join Date: Aug 2010
Posts: 26
A little more info on the codes... Before I installed the cooler and sensor I was pulling up P0218 (tran overheating condition) along with another that I think was the same as the one that's coming up now (P0714). Now after the cooler and sensor install I am only pulling up P0714 (transmission fluid temp sensor circuit, intermittent input). I took it to my mechanic and he is sort of stumped but is going to talk to a couple other tran guys about it. I really want to get this fixed because my poor Jeep is really shifting like crap now. Engine revs up past 2k rpm and holds then sharp jerk backward finally shifts then engine revs back up and then down all under 20mph and i am not accelerating fast (it's really less of a knocking now).
Anyone have any ideas!?
at7190 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
tranny problems cg2112 TJ Tech Forum 18 08-11-2010 11:13 AM
having problems with tranny install. filthy jeep TJ Tech Forum 6 10-06-2009 11:29 PM
89 YJ Tranny Problems beasst95 YJ Tech Forum 3 12-10-2008 12:40 PM
automatic tranny problems Barlow96 TJ General Discussion Forum 4 09-19-2008 02:50 PM
First post, tranny problems jody62 TJ Tech Forum 5 09-08-2007 08:11 AM



» Featured Product

All times are GMT -5. The time now is 12:00 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC