Transmission Issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-20-2013, 10:46 PM   #1
Jeeper
 
ThatWhiteMachine101's Avatar
 
Join Date: Apr 2011
Location: Chattanooga
Posts: 470
Transmission Issue

I own a 2004 TJ sport with a NV3550 5-Speed transmission with around 60k miles on it. It is difficult to shift into 1st and 2nd until it gets going. It can be a real pain to get it into second. It has seen some heavy offroad use and the transmission fluid was JUST changed to Royal Purple (I thought that was the problem because its never been changed) Any ideas?

__________________
2005 Patriot Blue TJ - Current love.
2004 Stone White TJ - Rest in Piece old girl.
ThatWhiteMachine101 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 12:01 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC