Transmission Mount - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-15-2007, 12:38 PM   #1
Jeeper
 
crj101's Avatar
 
Join Date: Feb 2007
Location: Scottsville, Kentucky
Posts: 179
Transmission Mount

Just wondered if they give much trouble. I have a vibration, not sure if it is the mount or a u-joint. Any thoughts? Thanks.

crj101 is offline   Quote Quick Reply
Old 09-17-2007, 05:48 PM   #2
Jack Lives Here!!!

WF Supporting Member
 
1BLKJP's Avatar
 
Join Date: Apr 2005
Location: Phoenix, AZ
Posts: 7,764
Are you running the stock tranny mount?

__________________
Thanks,
Jack Hickman

President - Arizona Off-Highway Vehicle Coalition
Vice-President - ASA4WDC
Arizona Rock Rats
1BLKJP is offline   Quote Quick Reply
Old 09-17-2007, 10:27 PM   #3
Jeeper
 
crj101's Avatar
 
Join Date: Feb 2007
Location: Scottsville, Kentucky
Posts: 179
As far as I know, yes. I bought it the way you see it. I did a tune-up at 100,000, thats all I've done to it. Why? Now 107,000.
crj101 is offline   Quote Quick Reply
Old 09-17-2007, 10:56 PM   #4
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,629
They aren't hard to change at all. Drop the transfer case skid, and crossmember and unbolt it from the transmission and install new one.
AzTJ is offline   Quote Quick Reply
Old 09-17-2007, 11:38 PM   #5
Jack Lives Here!!!

WF Supporting Member
 
1BLKJP's Avatar
 
Join Date: Apr 2005
Location: Phoenix, AZ
Posts: 7,764
Yes they do wear out. The main interior part of the mount is rubber. It will deteriorate after awhile. As AZ stated a very easy thing to replace. I think they are about 50 bucks from the dealer.
__________________
Thanks,
Jack Hickman

President - Arizona Off-Highway Vehicle Coalition
Vice-President - ASA4WDC
Arizona Rock Rats
1BLKJP is offline   Quote Quick Reply
Old 09-18-2007, 02:22 AM   #6
Jeeper
 
crj101's Avatar
 
Join Date: Feb 2007
Location: Scottsville, Kentucky
Posts: 179
Would the vibration be enough to cause a t-fluid leak? I have gotten a leak in the last month. I guess I will replace the trans mount and the u-joints and both seals. I have put dealer parts on my jeep, I have had good luck with them and not much diff. in price. Only a few bucks.
crj101 is offline   Quote Quick Reply
Old 09-18-2007, 02:25 AM   #7
Jack Lives Here!!!

WF Supporting Member
 
1BLKJP's Avatar
 
Join Date: Apr 2005
Location: Phoenix, AZ
Posts: 7,764
Quote:
Originally Posted by crj101 View Post
Would the vibration be enough to cause a t-fluid leak? I have gotten a leak in the last month. I guess I will replace the trans mount and the u-joints and both seals. I have put dealer parts on my jeep, I have had good luck with them and not much diff. in price. Only a few bucks.
I would say no. Odd are if you have a worn out tranny mount then you would hear some clunking when putting it in gear or going from drive to reverse.
__________________
Thanks,
Jack Hickman

President - Arizona Off-Highway Vehicle Coalition
Vice-President - ASA4WDC
Arizona Rock Rats
1BLKJP is offline   Quote Quick Reply
Old 09-18-2007, 05:01 AM   #8
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,629
Can ya see exactly where its leaking from? Might just be a worn out rear output seal.
AzTJ is offline   Quote Quick Reply
Old 09-18-2007, 09:20 AM   #9
Jeeper
 
Join Date: Oct 2005
Location: dunbar
Posts: 258
I had a bad tranny mount last year and the only thing it did was cause my jeep to pull to the right a little when starting out. Didn't make any noise or anything else. I only found it b/c I was changing my fluid and the tranny didn't look like it was sitting straight. I replaced it with a polyurethane one off e-bay for $20 and took 4 days to get.

__________________
There is someone in my head but it's not me

01 TJ SPORT,d44 w/true-trac in rear, 4 in. lift, 33's
mud707 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wrong manual transmission fluid listed in computer scotiez TJ Tech Forum 6 11-03-2012 10:03 PM
clacking in transmission stuck in reverse feels like neutral redhead_yooper YJ Tech Forum 6 12-20-2009 10:18 AM
How do you know if transmission mount is bad? 67mustang TJ Tech Forum 5 03-22-2008 12:00 AM
Crown Transmission Mount Kit for 87-90 Wrangler YJ w/ 4 Cylinder Engine (NY) $20 jamesx2 Classifieds Archive 0 02-08-2008 09:27 PM
tow bar for 2007 Wrangler X douglassoilco JK General Discussion Forum 5 09-08-2007 12:35 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:03 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC