trouble switching gears - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-13-2013, 06:25 AM   #1
Newb
 
Daniel Williams's Avatar
 
Join Date: Feb 2012
Posts: 5
trouble switching gears

My 06 jeep wrangler is an automatic. When I crank up and take off my jeep has a hard time switching gears. Especially in 1st and 2nd. It hesitates and then shifts hard enough to shake the vehicle. After about 2 or 3 take offs it subsides and runs great. Has anyone else had this problem?

Daniel Williams is offline   Quote Quick Reply
Old 06-13-2013, 06:28 AM   #2
Jeeper
 
itscakes's Avatar
 
Join Date: May 2013
Posts: 277
I'm guess it's automatic?? How many miles are on it? Could be your transmission going..... first thought

itscakes is offline   Quote Quick Reply
Old 06-13-2013, 06:39 AM   #3
Newb
 
Daniel Williams's Avatar
 
Join Date: Feb 2012
Posts: 5
Quote:
Originally Posted by itscakes View Post
I'm guess it's automatic?? How many miles are on it? Could be your transmission going..... first thought
It ain't got but 50, 000 miles on it
Daniel Williams is offline   Quote Quick Reply
Old 06-13-2013, 06:47 AM   #4
Jeeper
 
itscakes's Avatar
 
Join Date: May 2013
Posts: 277
Check your clutch fluid name sure it's full
itscakes is offline   Quote Quick Reply
Old 06-13-2013, 09:15 AM   #5
Full Size Jeep Dr.

WF Supporting Member
 
lindel's Avatar
 
Join Date: Nov 2011
Location: The land of Salted Iron
Posts: 1,891
I'd get the filter changed and fresh fluid in it. Your other option would be to open it up and examine the internals (or pay a shop to do it).
__________________
His: 1999 Flame Red TJ, With a few mods...

Hers: 1987 Grand Wagoneer, stock w/Falken Wildpeak ATs
lindel is online now   Quote Quick Reply
Old 06-13-2013, 11:02 AM   #6
Jeeper

WF Supporting Member
 
fishband's Avatar
 
Join Date: Jul 2011
Location: ORLANDO FL
Posts: 226
Several of us have had this problem and the only thing that solved it for me was replacing the pcm. I tried a transmission shop for the symptoms and after wasting time and money took it to the dealer. A new pcm and flashing it to the jeep was what finally solved the issue.....very pricey....also that tranny the 42rle requires an auxiliary cooler for it to behave and long life. There are threads on here which helped me figure it out. Search pcm or 42rle. Hope this helps.

__________________
I don't wanna grow up
fishband is online now   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:12 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC