Turn signal - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-25-2009, 10:22 PM   #1
Jeeper
 
cbrogan25's Avatar
 
Join Date: Mar 2009
Location: Greenville, NC
Posts: 29
Send a message via AIM to cbrogan25
Turn signal

I've had a couple electrical problems on my '00 TJ. I think I've found another one. Last week I was driving home one night and my left turn signal started blinking really fast when i'd turn it on- like they often do when a bulb goes out and then the light on the dash stayed on, which seemed to me like that must be the case. When I woke up and drove it the next morning, the turn signals worked fine. A couple days ago, it happened again so I decided to check it out. I looked at the bulbs and they looked fine, the filaments looked fine so I couldn't figure it out. I thought about just buying new bulbs to see if that would fix it but money's a little tight for me right now and i don't wanna be buying stuff i don't need (even tho bulbs arent' a huge investment).
I didn't think it could be the flasher because then all four signals would be affected, right?
Well today I had to commute for a seminar for work and all day they worked fine.

Anybody have any advice/ solutions?

cbrogan25 is offline   Quote
Old 03-25-2009, 10:29 PM   #2
Jeeper
 
n8smitty's Avatar
 
Join Date: Dec 2007
Location: Jupiter, Fl
Posts: 335
Send a message via AIM to n8smitty
Well my right rear light has been doing something similar for a few months now. I bought new bulbs and it still did it. I even bought a new tail light, plugged it in and it did the same thing. Try checking it with the headlights on and with them off. Mine work fine with the headlights off. When the headlights are on my turn signal doesn't work and it makes the other light pulsate. I can't figure it out either. Maybe I'll splice the wires and get rid of the plug and see if that helps it.

n8smitty is offline   Quote
Old 03-25-2009, 10:29 PM   #3
Jeeper
 
mikes05unlimited's Avatar
 
Join Date: Jan 2009
Location: wilmington nc
Posts: 485
I'm a newb but I saw a post on here a couple of days ago that someone had had the same problem and it turned out to be a rusty socket where the bulb goes in don't remember how they cleaned it but they said that it fixed the problem
mikes05unlimited is offline   Quote
Old 03-25-2009, 10:34 PM   #4
Jeeper
 
n8smitty's Avatar
 
Join Date: Dec 2007
Location: Jupiter, Fl
Posts: 335
Send a message via AIM to n8smitty
Thanks for the info. I'll have to find it and see if that helps.
n8smitty is offline   Quote
Old 03-25-2009, 10:47 PM   #5
Jeeper
 
cbrogan25's Avatar
 
Join Date: Mar 2009
Location: Greenville, NC
Posts: 29
Send a message via AIM to cbrogan25
Alright cool, I'll look into that too. n8smitty- Idk if this will help you any but your problem sounds kinda similar to another one I have. My ignition wires are loose so sometimes when I turn it on the radio doesn't turn on and the turn signals work funky- if i turn on the left signal, it makes my right brake light blink. And if I hit the brakes only one of the brakelights work. Anyway, all I have to do is turn the key a little bit forward it'll turn everything on and it works fine. I probably should fix it but i know how to deal with it so it doesn't bother me too much. doesn't sound exactly like what you've got going on but it might be worth looking into.
cbrogan25 is offline   Quote
Old 03-25-2009, 10:57 PM   #6
Jeeper
 
n8smitty's Avatar
 
Join Date: Dec 2007
Location: Jupiter, Fl
Posts: 335
Send a message via AIM to n8smitty
So far it's only been the passenger turn signal with the headlights on. I tried the two easy fixes and then just kinda forgot about it. I'm going to get into it a little more come summer time. Besides, I've lifted it, got new wheels and tires, and put new flares on it in the past month...so who cares about the turn signals. Thanks for the info.

n8smitty is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signal issue. kdukes4 TJ Tech Forum 8 03-12-2013 06:07 AM
flare turn signal wire colors jeepthing270 TJ Tech Forum 0 04-06-2008 05:01 PM
flare turn signal... foxinthemudd TJ Tech Forum 8 02-12-2008 02:17 AM
No turn signal...... Rebos_Guitarist YJ Tech Forum 5 11-28-2007 08:14 PM
Turn signal 89wrangler YJ Tech Forum 5 07-16-2007 09:00 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:54 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC