Turn signal issue. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-12-2008, 12:12 PM   #1
Jeeper
 
kdukes4's Avatar
 
Join Date: Apr 2008
Location: Maine
Posts: 679
Turn signal issue.

I'm having turn signal issues. driver side front turn signal wont blink properly. when i turn on my headlamps, the left turn signal on my dashboard is lit up. the ground looks fine, i took out the bulb and found that water had leaked inside of the socket causing a build up of this dark brown sludge around the connection between the bulb and socket. i cleaned it out but am having the same problem. Any suggestions? maybe a new socket? thanks!

kdukes4 is offline   Quote Quick Reply
Old 04-12-2008, 08:39 PM   #2
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
prob start w/ new socket.

__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 04-12-2008, 08:44 PM   #3
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
A new socket & bulb, and then a new flasher...

My mom's XJ's turn signals were acting up as well, they would stick or not work, ended up being the flasher going out. THAT WAS FUN to replace.
AzTJ is offline   Quote Quick Reply
Old 04-12-2008, 08:58 PM   #4
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
Quote:
Originally Posted by AzTJ View Post
A new socket & bulb, and then a new flasher...

My mom's XJ's turn signals were acting up as well, they would stick or not work, ended up being the flasher going out. THAT WAS FUN to replace.
where's the flasher on the xj, i've never changed one.
__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 04-12-2008, 09:00 PM   #5
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
Tucked under the dash on top of the steering column... on a '99.
AzTJ is offline   Quote Quick Reply
Old 04-12-2008, 09:11 PM   #6
Jeeper
 
jpdocdave's Avatar
 
Join Date: Mar 2008
Location: beach park, il
Posts: 8,162
Images: 7
ah, that one i've done, mine is 96, i don't think its as hard to find.
__________________
"The danger to America is not Barack Obama but a citizenry capable of entrusting a man like him with the Presidency. It will be far easier to limit and undo the follies of an Obama presidency than to restore the necessary common sense and good judgment to a depraved electorate willing to have such a man for their president."
http://mybroadband.co.za/photos/data...re_cowbell.gif
jpdocdave is offline   Quote Quick Reply
Old 04-12-2008, 09:21 PM   #7
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
I didn't take the dash apart though. I finaggled my arm up there and felt around. lol
AzTJ is offline   Quote Quick Reply
Old 04-23-2008, 05:17 PM   #8
Jeeper
 
kdukes4's Avatar
 
Join Date: Apr 2008
Location: Maine
Posts: 679
Hey guys, I went with a new socket and that fixed the problem. Thanks for the input, much appreciated.

Kyle
kdukes4 is offline   Quote Quick Reply
Old 03-12-2013, 06:07 AM   #9
Jeeper
 
popa's Avatar
 
Join Date: Jun 2009
Location: Romania
Posts: 241
Can anyone help me with the location of the relay (on a '00 TJ), please? My turn signals won't blink (they stay lit) and I guess it should be the relay (happened on another vehicle and that was the cause).
Thanks.

popa is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
turn signal short save_alkaline TJ Tech Forum 4 08-02-2009 02:03 PM
turn signal / radio problem nomik4u TJ Tech Forum 5 12-20-2008 12:55 PM
Weird Turn Signal Issue toddyfresh TJ Tech Forum 0 09-03-2008 07:31 PM
Turn Signal Problem** Johntom TJ Tech Forum 1 08-15-2008 05:01 PM
flare turn signal... foxinthemudd TJ Tech Forum 8 02-12-2008 02:17 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:08 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC