Turn Signal Issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-08-2013, 10:46 AM   #1
Jeeper
 
tkollman88's Avatar
 
Join Date: May 2013
Posts: 73
Turn Signal Issue

Hello,

New Jeep owner here. Just recently bought my 2005 LJ, love it!

My problem is, when I turn my lights on the right turn signal indicator stays lit. The right turn signal (small one on the fender flare) does not come on but it blinks when I turn the turn signal on. The whole right side blinks really fast which I know means I have a bad bulb but I have replaced it and it still does the same thing. My next step is going to be replacing the socket. Any other ideas?

Thanks in advance for your help!

tkollman88 is offline   Quote Quick Reply
Old 06-08-2013, 11:58 AM   #2
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: California/Nevada
Posts: 1,395
Bad bulb or socket either the side marker or more likely the front parking light on that side.

__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is offline   Quote Quick Reply
Old 06-08-2013, 12:05 PM   #3
Jeeper
 
Atthehop's Avatar
 
Join Date: Jul 2008
Location: NW, NJ
Posts: 3,924
Maybe bad grounds, does it have tail light guards?
__________________
Retired my 94 YJ 4cyl 5spd @ 200K
Now in a 04 TJ 4cyl 5spd CV @120K+
Both as a commuter vehicle in NW, NJ
April 2012.downsized and now a 99er.
Atthehop is offline   Quote Quick Reply
Old 06-08-2013, 01:14 PM   #4
Jeeper
 
Shelby427's Avatar
 
Join Date: May 2011
Location: Lakeland FL and Hooversville PA
Posts: 2,131
All four of the orange front lamps should come on when the lights are turned on, and the two on each side should flash opposite of each other on the same side,when the turn signal is on. When the front lamp flashes on, the side one goes off, and visa versa.

The bulb in the front of the fender is a dual filament bulb, the one on the side of the fender is a single. Check the front light bulb/socket/wiring for a problem.

Could be something as simple as a broken filament in the front bulb that's making contact with the other. This would turn off the side lamp but when the front flasher kicks off, the side one would work.
__________________
97 Sahara, 74 Renegade, 72 CJ5, 55 Willy's (the Beast) Boss 302, 6:34 gearing, Bose 901 speakers.
God I miss that Jeep. Forgot the kinda Jeep, 80 SX4.
Shelby427 is offline   Quote Quick Reply
Old 06-08-2013, 03:27 PM   #5
Jeeper
 
tkollman88's Avatar
 
Join Date: May 2013
Posts: 73
Quote:
Originally Posted by Atthehop View Post
Maybe bad grounds, does it have tail light guards?
No tail light guards.
tkollman88 is offline   Quote Quick Reply
Old 06-08-2013, 03:28 PM   #6
Jeeper
 
tkollman88's Avatar
 
Join Date: May 2013
Posts: 73
Quote:
Originally Posted by Shelby427 View Post
All four of the orange front lamps should come on when the lights are turned on, and the two on each side should flash opposite of each other on the same side,when the turn signal is on. When the front lamp flashes on, the side one goes off, and visa versa.

The bulb in the front of the fender is a dual filament bulb, the one on the side of the fender is a single. Check the front light bulb/socket/wiring for a problem.

Could be something as simple as a broken filament in the front bulb that's making contact with the other. This would turn off the side lamp but when the front flasher kicks off, the side one would work.
I just replaced the front bulb when it went out 3 days ago. It came in a two pack though so I will try the other bulb to make sure its not a problem with that one.
tkollman88 is offline   Quote Quick Reply
Old 06-08-2013, 03:37 PM   #7
Jeeper
 
Atthehop's Avatar
 
Join Date: Jul 2008
Location: NW, NJ
Posts: 3,924
Quote:
Originally Posted by tkollman88 View Post
No tail light guards.
Good they are well known for creating poor grounds and numerous light problems.
__________________
Retired my 94 YJ 4cyl 5spd @ 200K
Now in a 04 TJ 4cyl 5spd CV @120K+
Both as a commuter vehicle in NW, NJ
April 2012.downsized and now a 99er.
Atthehop is offline   Quote Quick Reply
Old 06-08-2013, 11:33 PM   #8
Jeeper
 
tkollman88's Avatar
 
Join Date: May 2013
Posts: 73
Still can't figure this out.

Now it is beeping at me while I'm driving down the road. If I turn my hazards on and off, the beeping goes away for 10 minutes or so. I also noticed that when I turn the hazard on, everything blinks normal (including the side bulb) except for the front bulb, it stays solid.

Any help with this is greatly appreciated.
tkollman88 is offline   Quote Quick Reply
Old 06-09-2013, 07:26 AM   #9
Newb
 
Join Date: Jun 2013
Posts: 8
I have Similar problems, back lights blink sometimes, fronts don't messing with the multi switch gets the backs going, I am going to look at Ground, then Multi switch.
Greenmann is offline   Quote Quick Reply
Old 06-09-2013, 02:26 PM   #10
Jeeper
 
tkollman88's Avatar
 
Join Date: May 2013
Posts: 73
Ok so apparently there was just a bad connection with the front marker bulb. I pulled it out just a little and everything works fine. Going to replace the socket and it should be fine.

tkollman88 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:54 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC