turn signal short - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-27-2008, 12:45 PM   #1
Jeeper
 
Join Date: Jul 2006
Location: Cincinnasty, OH
Posts: 93
turn signal short

got a new problem just today. my turn signals seem to have stopped working. when i hit it in either direction, the dash does nothing. no blink indicator light and no 'click click click', nothing. so i had someone look at my lights when i turned them on and they are just staying on. it's a solid light in whichever direction the turn signal is is in. so i'm guessing i have a short. oh, i checked the fuse which looks fine so i don't think that's it. is there a relay for the signals? or are there any commin wiring problems that might cause this? this is for my 2000 wrangler. TIA.

__________________
00 Wrangler - green and muddy

braverygone
save_alkaline is offline   Quote
Old 08-27-2008, 01:19 PM   #2
Jeeper
 
Join Date: Jul 2006
Location: Cincinnasty, OH
Posts: 93
i'm guessing it's something like this... i'll check my hazards and see if they work or not.

WikiAnswers - Where is the turn signal flasher on a 98 Jeep Wrangler

__________________
00 Wrangler - green and muddy

braverygone
save_alkaline is offline   Quote
Old 07-30-2009, 04:46 PM   #3
Jeeper
 
Ripp's Avatar
 
Join Date: Feb 2009
Location: Matzenbach, Germany
Posts: 16
Send a message via AIM to Ripp Send a message via MSN to Ripp Send a message via Yahoo to Ripp
I'm having the same problem on my 04 wrangler. I can't get them to flash at all. I replaced all the bulbs, replaced the fuse and still they dont flash. I also checked to see if they got brighter when put to right or left to signal manually and they still just stay dim when I have my head lights on. I do not know where the flasher thing is to check to see if its out?? Do you know where it is? It sucks not having signals due to me living on a Airforce base.
Ripp is offline   Quote
Old 07-31-2009, 12:06 AM   #4
Jeeper
 
Ripp's Avatar
 
Join Date: Feb 2009
Location: Matzenbach, Germany
Posts: 16
Send a message via AIM to Ripp Send a message via MSN to Ripp Send a message via Yahoo to Ripp
found the flasher its in the steering colum. wasn't bad and found out the fuse thats in the engine compartment was out I think it was #27 a 30 amp. now everything works.
Ripp is offline   Quote
Old 08-02-2009, 02:03 PM   #5
Jeeper
 
Join Date: Aug 2006
Location: Minnesota
Posts: 65
Check the wire connections to the back of the turn signal. Do you live in a climate where you get a lot of winter road grime/or even just from off-roading?

Mine got dirty after a nasty MN winter. They're very exposed under the front fender. First my turn signals didn't work. Then it got worse, when I'd turn on the turn signal the wipers would come on and stay on. I had to drive 25 miles home on a sunny day with no turn signals but the wipers going.

The maintenance guy where I work said to check ground wires. I didn't believe that a ground wire at the back of my turn signal light could cause the wipers to come on. But I cleaned the connections good, wrap them in electrical tape, and the problem was solved! Just a cheap and easy check to try. Good luck.
BlackJeepoftheFamily is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signal Problem** Johntom TJ Tech Forum 2 11-16-2014 01:23 PM
Turn signal issue. kdukes4 TJ Tech Forum 8 03-12-2013 06:07 AM
turn signal / radio problem nomik4u TJ Tech Forum 5 12-20-2008 12:55 PM
Weird Turn Signal Issue toddyfresh TJ Tech Forum 0 09-03-2008 07:31 PM
flare turn signal... foxinthemudd TJ Tech Forum 8 02-12-2008 02:17 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:23 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC