Turn Signals Don't Work, but Hazards do - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-24-2012, 02:04 PM   #1
j.e.b.'s Avatar
Join Date: Oct 2012
Posts: 15
Turn Signals Don't Work, but Hazards do

Hey guys, I have a 2000 TJ Sport. Today on my way back to work from my lunch break, I noticed that my turn signals were not turning on. I got out and made sure it wasn't just my dash lights not responding. The hazrds will come on so I know its not a bulb. What could be causeing this? A fuse maybe?

j.e.b. is offline   Quote
Old 10-24-2012, 02:42 PM   #2
cpierich's Avatar
Join Date: Apr 2012
Location: Red Lion, PA
Posts: 43
If I remember correctly this happened to me with my '97 TJ...can't remember if there was a fuse or the turn signal switch itself on the steering column...

cpierich is offline   Quote
Old 10-24-2012, 02:45 PM   #3
Join Date: Mar 2011
Posts: 840
Could also be the flasher unit.
Iceman is offline   Quote

2000 , blinkers , electrical , hazards , turn signals

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 10:03 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC