turn signals/hazard lights inoperative - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-02-2006, 07:35 PM   #1
Jeeper
 
Join Date: Jan 2006
Location: jacksonville fla
Posts: 17
Send a message via Yahoo to pennybuy
turn signals/hazard lights inoperative

The 97 TJ I just bought has no working turn signal/hazard lights...I got the Haynes manual but I'm a little at a loss for reading the schematics. I can do basic electronic testing but I can't seem to find the problem.

I've checked all the usual things...all bulbs are working...I replaced the turn/hazard relay...

The only thing I have found is..I think the former owner put in an alarm system at some point...it no longer works.
I believe there maybe a grounding problem with the turn/hazard system.

I'm not sure how to tell for certain...or how to check...

I removed the cover from the turn/hazard relay...and using 12v. test light was check for power to the relay...inside the relay case on the PC board are 5 solder joints..when I touched the light on two different solder joints the light lite up and the relay began to flash and the turn signals and hazard lights worked properly...however...when I turn off the turn signals and the hazard button ....the relay continued to click....
So, I thinking something is not grounded properly ...but have no idea where to go from here...any help would be greatly appreciated...

Thanks Bill....

PS...i was connecting the 12v. test light from a ground on the body to the relay...when everything started working properly..other than the relay constantly engaging..

pennybuy is offline   Quote Quick Reply
Old 01-02-2006, 07:48 PM   #2
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,176
Images: 2
The test light was providing a ground through the light bulb to that relay that then got everything working, that relay is obviously missing a switched ground from somewhere. I'd follow the connection on that relay through the schematic and see if you can figure out where it is supposed to get its missing switched ground from.

__________________
When you have a choice, buy American.

Jerry Bransford is online now   Quote Quick Reply
Old 01-03-2006, 12:47 PM   #3
Newb
 
Join Date: Aug 2005
Location: South East Michigan
Posts: 9
Check where the rear tailights are grounded to the tub. On the Jeep that I got the previous owner installed tail light guards and made the area where the lights/guards meet the tub get corroded, and thus giving me a bad ground, causing the same type of problems. Just an idea...
SolLess is offline   Quote Quick Reply
Old 01-03-2006, 09:48 PM   #4
Supporting Member

WF Supporting Member
 
daddyjeep's Avatar
 
Join Date: Apr 2005
Location: Smethport, PA
Posts: 2,398
If there is any equipment remaining from the no longer functioning alarm, I would get rid of that first. It may be a dead end for your current if it doesn't work anymore.
__________________
87 YJ, 5.2/46RH/NP231, Custom 4 link/ Radius Arms, Ballistic Nitrogen Shocks, 35" Cooper STT DaddyJeep build Thread:http://www.wranglerforum.com/f8/dadd...ld-122601.html
daddyjeep is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to turn off interior lights? troublemaker2171 TJ Tech Forum 18 01-25-2009 10:51 AM
crazy lights speepdaedeesi TJ General Discussion Forum 24 01-05-2009 09:44 AM
Turn Signal Problem** Johntom TJ Tech Forum 1 08-15-2008 05:01 PM
Turn signals went out...now my brake lights dont work? Kartik TJ Tech Forum 3 12-17-2007 03:50 PM
oem turn and park lights (NC) mudaddy Classifieds Archive 6 09-27-2007 06:57 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:34 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC