Unable to remove valve cover... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-04-2014, 05:31 PM   #1
Jeeper
 
Altonymous's Avatar
 
Join Date: Jun 2012
Location: Cary, NC
Posts: 112
Unable to remove valve cover...

I am trying to remove the valve cover on my 06 Unlimited Rubicon. All the bolts came out easy as expected. However, the wire harness at the back is pretty stuck tight. I'm afraid if I force it it will crack... any suggestions?
Attached Thumbnails
Click image for larger version

Name:	image-115723041.jpg
Views:	26
Size:	145.8 KB
ID:	950194  

Altonymous is offline   Quote Quick Reply
Old 04-04-2014, 06:24 PM   #2
Jeeper
 
Jeepboy89's Avatar
 
Join Date: Nov 2012
Posts: 157
Did you remove the nut in the stud in the rear. If so I would try a pry bar while jiggling it a little till it pops off it's kind of a pain but it will come off just needs a little convincing.

Jeepboy89 is offline   Quote Quick Reply
Old 04-04-2014, 06:25 PM   #3
Jeeper
 
Altonymous's Avatar
 
Join Date: Jun 2012
Location: Cary, NC
Posts: 112
Yeah all the bolts were free except the one under the plastic... So here's what finally worked.

I was able to get a wrench on the bolt underneath. I gave that a quarter turn to break it free. In doing so whatever bond was going on with the plastic also broke free. So then I was able to just push the clips back and pull it off.
Altonymous is offline   Quote Quick Reply
Old 04-04-2014, 07:15 PM   #4
Jeeper
 
Altonymous's Avatar
 
Join Date: Jun 2012
Location: Cary, NC
Posts: 112
Now I just have to figure out how to get the harness out of the way to remove the cover...
Altonymous is offline   Quote Quick Reply
Old 04-04-2014, 09:15 PM   #5
Jeeper
 
Altonymous's Avatar
 
Join Date: Jun 2012
Location: Cary, NC
Posts: 112
Okay so I got it off.. ended up removing the plastic harness cover, then there was enough room to get it out. Had to cut some tape and pop the tabs to do it.

But here's my next question..

The metal rings that go in each hole on the cover.. Is there supposed to be one for each hole? Even the one in the far back on the passenger side? Because I had all of them except that one. If there is supposed to be one for each hole then I'm missing one. Need to figure out what they are called so I can get another one. Hopefully I can get them at the parts store tomorrow.
Altonymous is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:30 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC