Weird RPM issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-04-2009, 01:52 PM   #1
tdm
Jeeper
 
tdm's Avatar
 
Join Date: Oct 2008
Location: Everett, WA
Posts: 58
Weird RPM issue

Starting to notice that when I'm driving down the road and going through the gears the RPMs drop very slowly in between shifts...this makes it hard to shift smoothly and is really starting to bug me.

Has anyone else had this issue as well? How do I fix it??

Thanks

tdm is offline   Quote Quick Reply
Old 02-04-2009, 09:12 PM   #2
Jeeper
 
Badboy's Avatar
 
Join Date: Dec 2008
Location: Godley,Tx.
Posts: 51
Check your transfer case shift lever to make sure its all the way in 4 hi.

__________________
2000 Tj work in progress...
Badboy is offline   Quote Quick Reply
Old 02-04-2009, 10:05 PM   #3
Jeeper
 
05GT-O.C.D.'s Avatar
 
Join Date: Sep 2008
Posts: 1,415
How many miles on your jeep? My first though was a dirty throttle body.
05GT-O.C.D. is offline   Quote Quick Reply
Old 02-04-2009, 10:18 PM   #4
Jeeper
 
Join Date: Nov 2006
Location: Chicago, IL
Posts: 8,286
Send a message via AIM to Triple88a Send a message via MSN to Triple88a Send a message via Yahoo to Triple88a Send a message via Skype™ to Triple88a
Assuming your engine is fully warmed up ^ 2x. Clean ur entire TB especially the IAC.
Triple88a is offline   Quote Quick Reply
Old 02-05-2009, 04:14 PM   #5
tdm
Jeeper
 
tdm's Avatar
 
Join Date: Oct 2008
Location: Everett, WA
Posts: 58
Thanks guys, I appreciate the help.

I cleaned the entire TB and IAC control this morning...the heep is definately running better. Much smoother and feels much snappier. Not sure that it really did anything for the RPM issue though. I was really amazed at how dirty everything was! Never figured it'd be so bad in an 05 with 33K on it. I'll just have to keep looking for the RPM issue, I sure hope it's not ECM related.
tdm is offline   Quote Quick Reply
Old 02-05-2009, 08:32 PM   #6
Jeeper
 
05GT-O.C.D.'s Avatar
 
Join Date: Sep 2008
Posts: 1,415
Another thing... I don't know where you're located, but it's been cold as heck here. Is your motor just idling higher for the first few miles trying to reach operating temp? If your motor is trying to maintain temp or warm up, that will play with your RPM's.

05GT-O.C.D. is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Tail light issue.. HELP? BBjmc TJ General Discussion Forum 21 11-30-2013 06:39 PM
Weird Blinker issue..... kuotown TJ Tech Forum 24 10-06-2009 09:42 PM
New Issue of JPFreek Adventure Magazine available now! txoutdoorx4 General Jeep Discussion 2 10-11-2007 01:53 PM
Anniversary issue of JPFreek Adventure Mag available Mon, 4/9 txoutdoorx4 Off-Topic 0 04-08-2007 08:54 PM
Weird electrical issue Geeps TJ Tech Forum 5 01-08-2007 02:49 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:12 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC