Wiper issues - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-11-2009, 07:49 PM   #1
Jeeper
 
catITguy's Avatar
 
Join Date: Feb 2009
Location: Metamora, IL
Posts: 449
Send a message via AIM to catITguy
Wiper issues

So winter is upon us and it didnt take long with all the salt spray to realize that my wipers arent working.....

I think the switch is probably not the problem, as the washer fluid pump still works fine. However I cannot move the wipers by hand at all - should I be able to? Im going to check fuses now, but if they are good, Im not sure what to check, shy of going out and buying a new wiper motor(s).

Any ideas/help is appreciated.

__________________
TJ Boot Camp Thread from Jeep Forum

2000 Wrangler Sport, 4.0L auto
OME 2.5" Suspension Lift
1.25" JKS BL and 1" MML
33x12.5 GoodYear Wrangler Duratracs
catITguy is offline   Quote Quick Reply
Old 12-11-2009, 09:16 PM   #2
Jeeper
 
catITguy's Avatar
 
Join Date: Feb 2009
Location: Metamora, IL
Posts: 449
Send a message via AIM to catITguy
well got it all pulled apart to the motor, it is quite rusty....like rusted crap just falling out....my guess is thats the culprit....going to head to NAPA tomorrow and see if they will let me buy one on the condition that if it doesnt fix my problem I can bring it back.

__________________
TJ Boot Camp Thread from Jeep Forum

2000 Wrangler Sport, 4.0L auto
OME 2.5" Suspension Lift
1.25" JKS BL and 1" MML
33x12.5 GoodYear Wrangler Duratracs
catITguy is offline   Quote Quick Reply
Old 12-12-2009, 03:03 PM   #3
Jeeper
 
catITguy's Avatar
 
Join Date: Feb 2009
Location: Metamora, IL
Posts: 449
Send a message via AIM to catITguy
So I got a new wiper motor, but the new motor has different color wires...I did 'best fit' and blew a fuse, so time to start searching the web (the documentation with the new motor is next to useless, jsut says connect the wires).

So on the jeep, the wires to the motor are: black, brown/white, pink/black, red/yellow, green/yellow.
On the motor, the wires are: Blue, black, green, red, black.

So anybody know which wires should go with which?
__________________
TJ Boot Camp Thread from Jeep Forum

2000 Wrangler Sport, 4.0L auto
OME 2.5" Suspension Lift
1.25" JKS BL and 1" MML
33x12.5 GoodYear Wrangler Duratracs
catITguy is offline   Quote Quick Reply
Old 12-12-2009, 03:50 PM   #4
Jeeper
 
Join Date: Nov 2008
Location: Lafayette, LA
Posts: 23
My wiper went out. The motor also. There was a rubber shroud on my original motor (to protect from moisture I assume). It seems to have been the culprit - it had water trapped in it, & the motor was rusty in there. It was blowing the fuse when I turned the ignition on. Bought a rebuilt one from Autozone. It plugge right in. Sounds like NAPA sold you the wrong one.
wiper1015 is offline   Quote Quick Reply
Old 12-12-2009, 04:32 PM   #5
Jeeper
 
catITguy's Avatar
 
Join Date: Feb 2009
Location: Metamora, IL
Posts: 449
Send a message via AIM to catITguy
I actually juts got it to work, and ended up getting it from Autozone. first time i connected it I crossed the intermittant control wires and that popped the fuse.

Rubber shroud also seemed to be the problem, based on the heavy rust in mine. Still got it replaced, all said and done for around $95...better than the couple hundred the stealership probably would have charged me.
__________________
TJ Boot Camp Thread from Jeep Forum

2000 Wrangler Sport, 4.0L auto
OME 2.5" Suspension Lift
1.25" JKS BL and 1" MML
33x12.5 GoodYear Wrangler Duratracs
catITguy is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Removing the wiper mechanism from the windshield frame 95 Wrangler YJ Banjo YJ Tech Forum 1 11-29-2009 05:03 PM
Wiring harness for rear wiper djbjeep TJ Tech Forum 0 06-15-2009 09:13 PM
Problem with rear wiper Dave57 Washington Jeep Forum 2 02-19-2008 10:05 AM
YJ Wiper Linkage Parts whiteyj YJ General Discussion Forum 3 08-09-2006 10:59 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:57 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC