Won't Start - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-24-2013, 04:03 PM   #1
Newb
 
Join Date: Aug 2013
Posts: 3
Unhappy Won't Start

2003 Jeep Wrangler Sahara 4.0 Ltr Automatic will not start. :-( New battery, new alternator. Now just stumped. Fuel pressure is fine. Air filter is clean.

SilverPlume is offline   Quote
Old 08-24-2013, 04:24 PM   #2
Jeeper
 
Owen_TJ's Avatar
 
Join Date: Sep 2010
Location: Denver, CO
Posts: 4,613
Do the accessories come on?

My initial guess is your actuator pin is shot
In case i'm right, here you go:

Owen_TJ is online now   Quote
Old 08-24-2013, 04:40 PM   #3
Jeeper
 
Notoriously_rob's Avatar
 
Join Date: Jun 2012
Posts: 686
Does it just click a lot? If so check your battery terminals and wires- if there is a lil rust on the cables it wont start- i have had that issue a few times-
Notoriously_rob is offline   Quote
Old 09-06-2013, 09:25 PM   #4
Newb
 
Join Date: Aug 2013
Posts: 3
Answer

It was a bad oil pump drive assembly that was ruining camshaft position sensors. Thanks guys for the suggestions. I learned a lot.
SilverPlume is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:45 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC