Wrong ATF - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-22-2008, 09:53 PM   #1
Jeeper
 
Joe Dirt's Avatar
 
Join Date: Mar 2007
Location: Murrieta, CA
Posts: 1,075
Wrong ATF

I had my transmission serviced at a shop a few months ago. It never really seemed to work as well after the service as it had before. Then a few weeks ago it started making a lot of noise. Someone on this site said it may have the wrong ATF in it. I checked it and it was dark instead of the cherry red ATF+4 should be. It didn't smell burnt and I wonder if it got serviced with some other type of ATF. I did a change today with ATF+4 and it works fine again. Do you think it caused any damage? I was thinking maybe I should go to the dealer where they can pump ALL the fluid out and replace it.

__________________
2013 Wrangler 2D, 3.6L, Automatic, 3.73 Gears, Limited slip in the rear, Teraflex 2" lift, 285/75/16 tires, LOD bumper & 8K winch, 2M Ham radio.

People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf- George Orwell
Joe Dirt is offline   Quote Quick Reply
Old 09-22-2008, 11:59 PM   #2
Jeeper
 
Join Date: Nov 2006
Location: Chicago, IL
Posts: 8,286
Send a message via AIM to Triple88a Send a message via MSN to Triple88a Send a message via Yahoo to Triple88a Send a message via Skype™ to Triple88a
i'd go and demand a free flush. Might not work since you already messed with it but its worth a shot.

Triple88a is offline   Quote Quick Reply
Old 09-23-2008, 12:16 AM   #3
Jeeper
 
Joe Dirt's Avatar
 
Join Date: Mar 2007
Location: Murrieta, CA
Posts: 1,075
The only issue is that I don't trust them to touch it anymore! I'm thinking I'll take it for a flush somewhere else and never go to that place again.
__________________
2013 Wrangler 2D, 3.6L, Automatic, 3.73 Gears, Limited slip in the rear, Teraflex 2" lift, 285/75/16 tires, LOD bumper & 8K winch, 2M Ham radio.

People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf- George Orwell
Joe Dirt is offline   Quote Quick Reply
Old 09-23-2008, 10:03 AM   #4
Jeeper
 
Rawkon's Avatar
 
Join Date: Apr 2005
Location: fullerton/big bear
Posts: 2,061
Send a message via AIM to Rawkon Send a message via MSN to Rawkon
go get it flushed by the dealer. If you look at your service receipt it states what kind of ATF they used. if it says atf +3 then its the wrong stuff. I had the same thing happen to me. after they completely flushed the trans for free and put in atf +4 all my issues went away. plus if your trans does go boom they worked on it last and put in the wrong fluid
Rawkon is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
Wrong manual transmission fluid listed in computer scotiez TJ Tech Forum 6 11-03-2012 09:03 PM
can someone tell me how this is wrong? (CB ant. mount) drummerwookie Communications and Electronics 3 11-18-2010 10:15 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 07:13 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC