Yet another Check engine light - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-06-2012, 04:47 PM   #1
Jeeper
 
KevinNJ's Avatar
 
Join Date: Jul 2012
Location: Morris County NJ
Posts: 337
Yet another Check engine light

I recently had a new 4.0L engine (jasper) dropped in my 2002 sport. Shortly after I got it back home on a cool morning start I got a check engine light. Shop had me bring it back in and it was code P0161. They replaced the sensor and since I couldn't get back to pick it up for a few days they had to jockey it around the lot until I could get there. One morning when moving it the check engine light comes on again, same code. They replace the sensor again and check that nothing is going to ground. Everything is ok. I pick up the jeep and use it a few days. Sunday morning I go to start it and the check engine light came one. Checked the codes and it P0161.
Any ideas? Could it be something simple like a gas cap? P0161 is circuit low voltage to bank 2 sensor 2. Not sure if it's just coincidental with the engine replacement or if something else is going on.
Thanks.

KevinNJ is offline   Quote
Old 12-06-2012, 11:45 PM   #2
Newb
 
Trauma85's Avatar
 
Join Date: May 2012
Posts: 7
Possiblely an exhaust leak infront of the sensor being that someone just put that engine in that's the first thing I would check. Other than that I can't give you any advise without knowing what your fuel trim is doing and how that sensor reacts to manual changing of af ratios. I've seen where the upstream sensor is reading wrong and giving the pcm a false af ratio reading and causing it to think that he downstream sensor is bad. Hard to tell without having a computer hooked up
Trauma85 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:07 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC