1 out of 3 brake lights - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-08-2012, 05:26 PM   #1
Newb
 
Join Date: Dec 2011
Posts: 9
1 out of 3 brake lights

95 YJ I had all 3 brake lights working,[tail lights work] then drivers side went out. I checked and cleaned bulb and socket put it back and both sides quit. The only brake light working is the one over the spare tire. Tail lights still work. Any ideas?

konajeep is offline   Quote
Old 03-08-2012, 05:28 PM   #2
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,299
You've probably got a loose or bad ground. If the light worked before you had it apart, then I would look at connections etc for corrosion...

__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote
Old 03-08-2012, 06:31 PM   #3
Newb
 
Join Date: Dec 2011
Posts: 9
middle light

Why do i have the middle light working? Any ideas where to look for bad ground
konajeep is offline   Quote
Old 03-08-2012, 07:57 PM   #4
Jeeper
 
Master4th's Avatar
 
Join Date: Mar 2012
Posts: 341
The Tail Lights are ground through the housing to the body. There are 3 bolts that hold your tail lights on. Those are the grounding bolts as well.

Maybe your brake switch is bad, its connected to the brake pedal. Play with it and see if you get any flickers.
Master4th is offline   Quote
Old 03-08-2012, 11:51 PM   #5
Jeeper
 
Dutch 95's Avatar
 
Join Date: Feb 2011
Location: Michigan
Posts: 311
Images: 3
Quote:
Originally Posted by Master4th View Post
The Tail Lights are ground through the housing to the body. There are 3 bolts that hold your tail lights on. Those are the grounding bolts as well.
If you are positive that the bulbs are not blown, I will second that^^^^^. Those mounting bolts are the ground for the lights and have to be clean!

You could also check/clean the connections in the wiring harness leading to the tail lights in each corner (looking up into each back corner from the underside). Disconnect, clean, add dielectric grease.

Because the center tail light works, I would doubt the break switch is the issue.
Dutch 95 is offline   Quote
Old 03-11-2012, 03:33 PM   #6
Newb
 
Join Date: Dec 2011
Posts: 9
Thanks it was the wiring plug under the dash. Corrosion

konajeep is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 - year of the lemon OH9JK JK General Discussion Forum 246 07-20-2012 03:53 PM
Noise while clutch is out raycer YJ Tech Forum 11 03-11-2012 02:52 PM
any meets out here? 00tjsprt General Jeep Discussion 2 03-09-2012 03:06 PM
Fog Lights Roadhawg General Jeep Discussion 1 03-09-2012 02:08 PM
First topless day of the year billybob3358 TJ General Discussion Forum 1 03-08-2012 01:24 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:34 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC