1989 wrangler 2.5l starts, once high idle is over it sputters and stalls. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-03-2011, 05:18 PM   #1
Jeeper
 
howella64759's Avatar
 
Join Date: Aug 2011
Location: lamar,mo
Posts: 34
Images: 3
1989 wrangler 2.5l starts, once high idle is over it sputters and stalls.

i have the 1989 2.5l tbi jeep wrangler. once i start it, it idles high for just a little, then the idle slowly goes down until it hits 400-500 and stalls. if i press the gas it goes back to normal for about 15-20seconds then does it again. sometimes it will run fine and not sputter, but then most of the time it will sputter. everything is stock under the hood, and all wires appearto be in place and secure as well. have since used fuel treatment, changed the fuel filter as well. but no good. i pulled the spark plugs and they look great. i pulled the air filter and it is new. looked down the tbi and it is black down inside with what appears to be soot.

i am a new jeeper and have searched the forum for this but all i get is cold weather issues. any help would be wonderful.

__________________
1989 jeep wrangler 2.5L, AX-5, NP231

As an adult i didnt know i could be grounded any more, but i was just grounded from my jeep until i mow the yard.
howella64759 is offline   Quote Quick Reply
Old 09-04-2011, 02:55 AM   #2
Jeeper
 
Join Date: Aug 2011
Location: Tampa
Posts: 258
Sounds like its time to buy a can of carb or throttle body cleaner. As far as spraying it with the engine running or shut off, read the directions on the can.

Copperhead is offline   Quote Quick Reply
Old 09-04-2011, 11:33 PM   #3
Jeeper

WF Supporting Member
 
Join Date: Aug 2011
Posts: 43
Try pulling the emisions electrical plug behind the carb and then go for a drive, worked for me. Gonna install a weber carb soon.
1990 jeep is offline   Quote Quick Reply
Old 09-05-2011, 09:04 AM   #4
Jeeper
 
Blackbull's Avatar
 
Join Date: Sep 2011
Location: Nicholasville ky
Posts: 41
I would check all vac lines
Blackbull is offline   Quote Quick Reply
Old 09-05-2011, 01:10 PM   #5
Jeeper
 
howella64759's Avatar
 
Join Date: Aug 2011
Location: lamar,mo
Posts: 34
Images: 3
will definitely try those solutions. thank you guys. have been google'ing around trying to find the 4wd actuator harness( ibelieve its all vacuum) , they are all cracked. i am also looking for the actual dash panel. the top of the panel is completely rusted through.

i found a plug that doesnt go to anything. here is a pic of it. just wondering if anybody knows what it goes to.
Attached Thumbnails
Click image for larger version

Name:	SANY0062.JPG
Views:	72
Size:	198.4 KB
ID:	66582   Click image for larger version

Name:	SANY0063.JPG
Views:	63
Size:	181.2 KB
ID:	66583  

__________________
1989 jeep wrangler 2.5L, AX-5, NP231

As an adult i didnt know i could be grounded any more, but i was just grounded from my jeep until i mow the yard.
howella64759 is offline   Quote Quick Reply
Old 09-05-2011, 01:27 PM   #6
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,291
That appears to be from the power steering unit
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote Quick Reply
Old 09-05-2011, 03:39 PM   #7
Jeeper
 
howella64759's Avatar
 
Join Date: Aug 2011
Location: lamar,mo
Posts: 34
Images: 3
my wrangler doesnt have power steering, so i am guessing this will just remain unused.
__________________
1989 jeep wrangler 2.5L, AX-5, NP231

As an adult i didnt know i could be grounded any more, but i was just grounded from my jeep until i mow the yard.
howella64759 is offline   Quote Quick Reply
Old 09-06-2011, 11:37 AM   #8
Jeeper
 
howella64759's Avatar
 
Join Date: Aug 2011
Location: lamar,mo
Posts: 34
Images: 3
i tried the tbi cleaner, and reran all the 4wd actuator vacuum lines( there were tons of holes in them). the 4wd light still doesnt come on so i dont know what is wrong there but, still having the sputtering and stalling issue.
__________________
1989 jeep wrangler 2.5L, AX-5, NP231

As an adult i didnt know i could be grounded any more, but i was just grounded from my jeep until i mow the yard.
howella64759 is offline   Quote Quick Reply
Old 09-06-2011, 11:39 AM   #9
Jeeper
 
howella64759's Avatar
 
Join Date: Aug 2011
Location: lamar,mo
Posts: 34
Images: 3
Quote:
Originally Posted by Garyk View Post
That appears to be from the power steering unit

that line in the pic runs from front to back on the drivers side along the valve cover. i dont have power sterring, just the manual steering box.
__________________
1989 jeep wrangler 2.5L, AX-5, NP231

As an adult i didnt know i could be grounded any more, but i was just grounded from my jeep until i mow the yard.
howella64759 is offline   Quote Quick Reply
Old 09-06-2011, 11:40 AM   #10
Jeeper
 
howella64759's Avatar
 
Join Date: Aug 2011
Location: lamar,mo
Posts: 34
Images: 3
also when i check the vin number, it isnt coming out right. it says it is a canadian model, and the engine code says p which doesnt cover any engine model in any of the vin decoders.
__________________
1989 jeep wrangler 2.5L, AX-5, NP231

As an adult i didnt know i could be grounded any more, but i was just grounded from my jeep until i mow the yard.
howella64759 is offline   Quote Quick Reply
Old 09-06-2011, 11:41 AM   #11
Newb
 
Join Date: Sep 2011
Posts: 7
Mine had this, and in 100 degree GA weather, i knew it wasn't "cold weather issues". we ended up rebuilding the throttle body, and its worked fine for the past 8 months. the problem was that it was flooding the engine all by itself, and the throttle was being left almost wide open, then would slam shut.
johnley is offline   Quote Quick Reply
Old 09-07-2011, 04:05 PM   #12
Jeeper
 
howella64759's Avatar
 
Join Date: Aug 2011
Location: lamar,mo
Posts: 34
Images: 3
so i found that my 4wd light doesnt come on, googled it and searched this forum, and found that my 4wd actuator harness was completely demolished. I got some vacuum tubing and fixed all the leaks. Everything seems to be connected according to all the schematics i can possibly find, except for the red wire. i see all the diagrams that say to connect it to the manifold, but can somebody attach a photo of exactly where i am needing to connect the red vacuum tubing. thanks guys.
__________________
1989 jeep wrangler 2.5L, AX-5, NP231

As an adult i didnt know i could be grounded any more, but i was just grounded from my jeep until i mow the yard.
howella64759 is offline   Quote Quick Reply
Old 09-07-2011, 04:11 PM   #13
Newb
 
Join Date: Sep 2011
Location: Christiansburg
Posts: 2
2.5l starting problems

Hello,

If the vacuum lines don't fix the problem, you might try the ignition coil. I had a very similar problem on my 1992 YJ. It would start sometimes, idle a while and die. Sometimes it would run for a few seconds. The test is to pull a plug and see if it's wet or severely carboned up. Good luck - hope you find your problem.
willyt2011jk is offline   Quote Quick Reply
Old 09-07-2011, 08:44 PM   #14
Jeeper
 
howella64759's Avatar
 
Join Date: Aug 2011
Location: lamar,mo
Posts: 34
Images: 3
the pluga are all new and gapped good. when it starts to idle down and sputter, if i gently push the gas it will run fine again until i let off the gas.
__________________
1989 jeep wrangler 2.5L, AX-5, NP231

As an adult i didnt know i could be grounded any more, but i was just grounded from my jeep until i mow the yard.
howella64759 is offline   Quote Quick Reply
Old 09-07-2011, 08:45 PM   #15
Jeeper
 
howella64759's Avatar
 
Join Date: Aug 2011
Location: lamar,mo
Posts: 34
Images: 3
Quote:
Originally Posted by willyt2011jk View Post
Hello,

If the vacuum lines don't fix the problem, you might try the ignition coil. I had a very similar problem on my 1992 YJ. It would start sometimes, idle a while and die. Sometimes it would run for a few seconds. The test is to pull a plug and see if it's wet or severely carboned up. Good luck - hope you find your problem.
to everybody, thank you for all the suggestions, i will try everything anybody posts. just wanna get my $700 jeep alive and well.. Once she is healthy i can even give her a name..
__________________
1989 jeep wrangler 2.5L, AX-5, NP231

As an adult i didnt know i could be grounded any more, but i was just grounded from my jeep until i mow the yard.
howella64759 is offline   Quote Quick Reply
Old 12-11-2011, 01:11 PM   #16
Jeeper
 
Blackbull's Avatar
 
Join Date: Sep 2011
Location: Nicholasville ky
Posts: 41
I have an 87 2.5 tbi that had the same problem and I changed the vac lines that didn't fix it then went to changing every senser like the map, o2, and tps it took awhile but it cleared up and runs great

Blackbull is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:36 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC