1990 YJ Clutch issues... - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-04-2013, 01:37 AM   #1
Newb
 
Join Date: Jul 2013
Posts: 2
1990 YJ Clutch issues...

Hello,

I have been reading posts, all the replies and have learned a lot over the past few hours.

Jeep was running awesome. Had it out on the Highway, top off, a truly wicked day. Stopped for 5 minutes, all of a sudden the car won't run and the clutch is floppy. The Master cylinder is empty. Filled it. Bled the system (as best I can) and am not getting any firmness returning to the clutch. I have a 90 YJ so the slave is in the bell housing and I bled it from the bleeder under the jeep. Also read that you can bleed it from the master cylinder. Bleeding is not working and now the clutch line is leaking from the end that attaches to the Master cylinder. Is it possible that I f&$%ed up the line. I swear I didn't tighten it too much. It is very weird that it is leaking from there.

Any tips tricks for getting me back on the road. Right now it is parked in a public lot 20 blocks away.

Thanks for any help.

__________________
Jeep = Awesome!
Vesey is offline   Quote
Old 07-04-2013, 08:54 AM   #2
Jeeper
 
AllMudd's Avatar
 
Join Date: Apr 2013
Location: SoCal
Posts: 1,610
Sounds to me like you need to replace the line. Old lines are brittle so it so won't take much to damage old parts. Also (just to get it home) will it start without the trans in gear? If so put it in first, crank it up (it will buck a little but just give it some gas) and take the nice slow ride home and avoid stopping as possible.

AllMudd is offline   Quote
Old 07-04-2013, 06:17 PM   #3
Newb
 
Join Date: Jul 2013
Posts: 2
Got it home but black smoke from the tail pipe.

Amazingly the "Leave the cap off for a few hours after tap dancing on the clutch (~150 times)" method that I read somewhere worked. I managed to limp it home. Runs like S&!# right now???? Puffin all kinds of dark smoke when I start it up and when I change gears.

Rumor has it that my seals are gone. Any tips on how to go about replacing them. Engine rebuild?
__________________
Jeep = Awesome!
Vesey is offline   Quote
Reply

Tags
clutch

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:04 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC