1991 Clutch problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-12-2009, 09:34 AM   #1
Newb
 
Join Date: Jun 2009
Posts: 2
1991 Clutch problem

I went to drive my jeep the other day and the clutch would not disengage. It worked one day and did not the next. Clutch pedal feels OK but it doesn't disengage the clutch at all. I don't see any fluid leaking. Anyone see this problem before or have any ideas?

JimmyKeith is offline   Quote Quick Reply
Old 06-12-2009, 10:12 AM   #2
Jeeper
 
scrambler1's Avatar
 
Join Date: Jan 2008
Location: vermont
Posts: 486
1) check your fluid level.
2) bleed slave cylinder,just like bleeding a brake system but smaller and easier.

If this does not do it,sounds like you need a new slave cylinder.
Pretty common,they do not last forever.

__________________
94' wrangler 4 cyl. 5 speed D30/8.8 ARB
82' scrambler 350 TBI/700r4 D30/Currie 9"
07' JK sahara
Whats the deal with the facebook crap?? ->->->->
Grown men should NOT be on Facebook.
scrambler1 is offline   Quote Quick Reply
Old 06-12-2009, 12:05 PM   #3
Jeeper
 
Join Date: Apr 2009
Posts: 538
like scrambler says check and bleed fluid if low. if bleeds good and pedal feels good but doesnt release still i would suspect warped disc or cracked pressure plate. Keep in mind its how clutch feels. if slave or master is done pedal will have a lower contact area or freeplay or even go to the floor easily. only you know what it felt like before.
dooder is offline   Quote Quick Reply
Old 06-12-2009, 02:36 PM   #4
Newb
 
Join Date: Jun 2009
Posts: 2
One more thing to consider

Fluid isn't low and the pedal feels OK. One more piece of the puzzle - I did drive it in 2 feet of water the last time out.
JimmyKeith is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
Clutch Problem again acopsy88 TJ Tech Forum 4 11-09-2007 10:27 AM
Fan Clutch Problem krankieone TJ Tech Forum 9 02-24-2007 01:05 AM
1991 wrangler taillight problem perrypeckslip YJ Tech Forum 1 09-29-2006 08:04 PM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 12:36 AM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:42 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC