1994 Wrangler loss of power - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-04-2014, 01:55 PM   #1
Newb
 
Join Date: Mar 2014
Posts: 5
1994 Wrangler loss of power

I have a 1994 Jeep Wrangler with 2.4 4 cylinder engine. I was driving from Washington state to Arizona and during my drive I was having a loss of engine power. At some points i could not get over 50 mph. I changed the PCV and O2 sensor along the way and it was no help. Any ideas of what might be causing this. I need to get this Jeep to North Carolina.

Angelsfan1 is offline   Quote Quick Reply
Old 03-04-2014, 01:58 PM   #2
Jeeper
 
Aunt Flow's Avatar
 
Join Date: Jan 2012
Location: Northern California, where the girls are warm.
Posts: 491
Uphill, downhill, flat ground?

__________________
There are two kinds of people in this world...
Aunt Flow is offline   Quote Quick Reply
Old 03-04-2014, 02:03 PM   #3
Newb
 
Join Date: Mar 2014
Posts: 5
Correction. 2.5 4 Cylinder
Angelsfan1 is offline   Quote Quick Reply
Old 03-04-2014, 02:04 PM   #4
Newb
 
Join Date: Mar 2014
Posts: 5
Little bit of both uphill and flat ground.
Angelsfan1 is offline   Quote Quick Reply
Old 03-04-2014, 02:08 PM   #5
Jeeper
 
W5KVV's Avatar
 
Join Date: Oct 2013
Location: S.E. Oklahoma
Posts: 824
Any symptoms? Is it running rough or sputtering? Also, is it running warmer than normal?

Right off the bat I'm wanting to say the cat may be on its way out. I had the same thing happen to me on a long road trip, long story short the cat clogged up.
__________________
1995 Rio Grande - 4"RC - 1/2"booms - 33's - 4:88's - 1"MML -
Belly up/302/NP435/NP208/8.8 swap about to start
http://i42.photobucket.com/albums/e3...g?t=1411201524
W5KVV is offline   Quote Quick Reply
Old 03-04-2014, 02:13 PM   #6
Newb
 
Join Date: Mar 2014
Posts: 5
Yes it was running rough and sputtering at times. Engine temp was normal.

I know I need a new exhaust system. Did not think of the CAT. I was thinking fuel pump but that is a bear to get to. No access plate.
Angelsfan1 is offline   Quote Quick Reply
Old 03-04-2014, 02:18 PM   #7
Jeeper
 
W5KVV's Avatar
 
Join Date: Oct 2013
Location: S.E. Oklahoma
Posts: 824
Do you have a check engine light on & do you know how to read the codes?
__________________
1995 Rio Grande - 4"RC - 1/2"booms - 33's - 4:88's - 1"MML -
Belly up/302/NP435/NP208/8.8 swap about to start
http://i42.photobucket.com/albums/e3...g?t=1411201524
W5KVV is offline   Quote Quick Reply
Old 03-04-2014, 02:31 PM   #8
Supporting Member

WF Supporting Member
 
nmill5321's Avatar
 
Join Date: Aug 2012
Location: Newburyport MA
Posts: 511
One of my trucks had the same problem. It couldn't get out of it's own way and barely got over 30 mph. Changed the cat and everything was back to normal. I would definitely check out your cat.
__________________
"Some days you eat the bear, and some days the bear eats you"

My Build: '92 YJ 4.0, AX15 with 4" RC lift, SYE, Tom Woods drive shaft, 33x12.50 Hankook Dynapro MT, 4.10's

-Nick
nmill5321 is offline   Quote Quick Reply
Old 03-04-2014, 04:43 PM   #9
Newb
 
Join Date: Mar 2014
Posts: 5
Yes the check engine light did come on and it was for the O2 sensor that we changed.

I think I will take a look at the CAT. Like I said I know I have to replace the exhaust system

Angelsfan1 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:29 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC