1995 Wrangler YJ fuel problems/Not Starting - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-03-2013, 10:11 PM   #1
Newb
 
Join Date: Jun 2013
Posts: 4
1995 Wrangler YJ fuel problems/Not Starting

Hey whats up guys...So I just bought a 1995 Wrangler YJ 2.5 Inline 4 cylinder...Jeep is not running was told by previous owner that he was stopped at a red light and jeep turned off and hasnt started since...I saw Jeep sitting i his backyard for a year then I came and bought it...I put a battery in it and car cranks over but does not start..
1. checked main fuel line and noticed that there was no fuel being delivered
2. changed fuel pump but still no fuel being delivered
3. checked fuses and still no fuel delivered and jeep just cranks over

Please if anyone can help me out with this problem I would greatly appreciate it....

Thanks Alex

1995jeepwrangleryj is offline   Quote Quick Reply
Old 06-03-2013, 11:07 PM   #2
Jeeper
 
AllMudd's Avatar
 
Join Date: Apr 2013
Location: SoCal
Posts: 1,462
Where are you checking for fuel at?

AllMudd is offline   Quote Quick Reply
Old 06-03-2013, 11:08 PM   #3
Jeeper
 
AllMudd's Avatar
 
Join Date: Apr 2013
Location: SoCal
Posts: 1,462
Also do you hear a humming when you take off the fuel cap? If not then the pump isn't turning on
AllMudd is offline   Quote Quick Reply
Old 06-04-2013, 12:47 AM   #4
Newb
 
Join Date: Jun 2013
Posts: 4
No humming noise so I know fuel pump isnt getting power, however I dont know why it is not getting power...I am checking for fuel on the main fuel line in the motor
1995jeepwrangleryj is offline   Quote Quick Reply
Old 06-04-2013, 02:15 AM   #5
Jeeper
 
Join Date: Aug 2009
Location: Hinesville, Ga
Posts: 222
Check and clean the c104 relay mounted on the firewall next to the battery. I had the same problem and it took a long time to find that this relay was dirty and causing the same not fuel delivery problem.
tim2 is offline   Quote Quick Reply
Old 06-04-2013, 06:14 AM   #6
Jeeper
 
indirocz28's Avatar
 
Join Date: Feb 2013
Location: Fort Hood/ BCS, TX
Posts: 1,044
Also, check at the connector in the rear left corner to see if you are getting power back there.

We know you replaced the pump, but it doesn't hurt to verify power coming or not coming through the connector.

Also check for wiring harness' that have possibly been chewed by rodents.

I just had to diagnose a Jeep ZJ where it quit, and the owner searched for the issue for about 3 weeks until he asked me to look at it.
__________________
MY1990 "Little YJ" Build: http://www.wranglerforum.com/f8/brou...ay-242064.html
Come wheel with us at Brazos Valley Off Road Ranch! http://www.wranglerforum.com/f53/bra...tx-237657.html
indirocz28 is offline   Quote Quick Reply
Old 06-04-2013, 11:07 PM   #7
Newb
 
Join Date: Jun 2013
Posts: 4
So I tried pouring gas down the throttle body just to see if I could get the motor fired up but still not starting just cranks over...
1995jeepwrangleryj is offline   Quote Quick Reply
Old 06-04-2013, 11:07 PM   #8
Newb
 
Join Date: Jun 2013
Posts: 4
Any other useful hints.....
1995jeepwrangleryj is offline   Quote Quick Reply
Old 06-04-2013, 11:36 PM   #9
Jeeper
 
indirocz28's Avatar
 
Join Date: Feb 2013
Location: Fort Hood/ BCS, TX
Posts: 1,044
Bad crank sensor?

Have you tested for spark?
__________________
MY1990 "Little YJ" Build: http://www.wranglerforum.com/f8/brou...ay-242064.html
Come wheel with us at Brazos Valley Off Road Ranch! http://www.wranglerforum.com/f53/bra...tx-237657.html
indirocz28 is offline   Quote Quick Reply
Old 06-05-2013, 12:22 AM   #10
Jeeper
 
AllMudd's Avatar
 
Join Date: Apr 2013
Location: SoCal
Posts: 1,462
I can't remember but is there a fuel pump relay under the hood by the battery? And sounds like you have more than one problem since fuel directly into the engine it won't fire.
AllMudd is offline   Quote Quick Reply
Old 06-05-2013, 02:45 AM   #11
Jeeper
 
Join Date: Aug 2009
Location: Hinesville, Ga
Posts: 222
Yes there is a pump relay located in the fuse box located right in front of the battery.

tim2 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 09:30 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC