1995 YJ grounds... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-11-2013, 05:22 PM   #1
Jeeper
 
TonyGreen's Avatar
 
Join Date: Mar 2013
Location: Chicago
Posts: 25
Question 1995 YJ grounds...

Hey Everybody!!

My wrangler: 1995 YJ 2.5L 5 Speed

I was wondering which are the grounds that have anything to do with starting the car? As some of you might know, I still haven't been able to start my car. I have checked two grounds the battery ground and the starter/frame ground.

I was told that there are 6, is that true? Also where are they located?

I did research around but have not found a definite answer.

Thanks

TonyGreen is offline   Quote
Old 03-11-2013, 05:34 PM   #2
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,299
I think the rest are frame to body. There might be one from the firewall too. If you have a good ground at the engine and at the frame the starter should spin

__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote
Old 03-11-2013, 07:27 PM   #3
Jeeper
 
TonyGreen's Avatar
 
Join Date: Mar 2013
Location: Chicago
Posts: 25
alright, thanks. The starter does crank (turn over). Its just that the engine does not start. I think it is a ground cable.

Thanks for the feedback...
TonyGreen is offline   Quote
Old 03-11-2013, 08:50 PM   #4
Jeeper
 
Join Date: Jul 2006
Location: columbus
Posts: 2,156
Send a message via AIM to rebelBullDawg325
should be a ground that attaches to the bracket for the e-brake pedal. i think it is for the fuel pump or something in the fuel system
__________________
91' - 4.0L - 5spd
31" bfg at's
rebelBullDawg325 is offline   Quote
Old 03-11-2013, 09:04 PM   #5
Jeeper
 
TonyGreen's Avatar
 
Join Date: Mar 2013
Location: Chicago
Posts: 25
Re: grounds

Quote:
Originally Posted by rebelBullDawg325 View Post
should be a ground that attaches to the bracket for the e-brake pedal. i think it is for the fuel pump or something in the fuel system
Thank you! I will check that.. at this point anything is game.
TonyGreen is offline   Quote
Old 03-12-2013, 08:41 PM   #6
Jeeper
 
TonyGreen's Avatar
 
Join Date: Mar 2013
Location: Chicago
Posts: 25
My problem was definately electrical most likely PCM. The car is running now after following ambushtom's advice on his thread "YJ dies... PCM and Grounding issue" it could also be the fact that I cleaned the fuses and relays in the engine compartment and also the ones underneath the steering wheel.

Thanks

TonyGreen is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:35 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC