1995 yj hard start, high idle, and cuts out - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-13-2013, 12:43 AM   #1
Newb
 
Join Date: Jun 2013
Posts: 6
1995 yj hard start, high idle, and cuts out

can anyone help? i have a 1995 YJ and it sat for about a year.. i just got done changing out the freeze plugs and it started having a hard time starting. i put new gas and fuel booster in the tank that didnt help.. i changed the fuel filter and pump and that didnt fix it either. it has 140,000 miles on it. i dont know where to go from here? could the O2 sensor be causing it? the coolant might have dripped down on to it from the freeze plugs leaking. it will crank over a bunch and sometimes start. when it starts it runs rough until it catches it self and revs up to about 2500 rpm and stays there. then when i drive it it will cut out bad under acceleration and feels like its missing. but when the rpms get higher up its seems fine when i lets off the gas it wont idle down it stays between 2000 and 2500 rpms

Scotts1995yj is offline   Quote
Old 06-13-2013, 07:56 AM   #2
Founder, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,952
Im going to say either bad battery cables, bad connections at the battery, bad connections at the starter or possibly a bad battery itself. Thats the kind of crap they'll do when they don't get a solid voltage to the fuel injectors. Also check your grounds.


Or, distributor cap and rotor & spark plugs. They're cheap... start there.

I'll bet if you go through all your connections something is loose. If not, start w/the parts designed to fail like cap & rotor.

Or, IF it only does it when wet, its the coil.

__________________
-Chris
Founder, ThumbJeeps


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote
Old 06-13-2013, 11:11 PM   #3
Newb
 
Join Date: Jun 2013
Posts: 6
i replaced the battery about a month ago. i changed out the coil and spark plugs today. when i changed the coil it really didnt help much.. but with the spark plugs it helped my problem with starting.. now the jeep starts right up but still idles very high and still feels like its going to fall on its face when im accelerating.. everytime ive changed someting fuel pump fuel filter ignition coil it seems like it gets a tiny bit better. but noting drastically has made it better.. i checked the ground and it seems fine, the cap and rotor arent very old
Scotts1995yj is offline   Quote
Reply

Tags
cuts out , hard start , high idle

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:33 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC