1st jeep. Serious problems. Any ideas are welcome - Page 2 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-22-2010, 01:43 AM   #31
Jeeper
 
Join Date: Sep 2010
Location: Wahiawa, HI
Posts: 31
Quote:
Originally Posted by trebor46 View Post
It's possible for the center pin to have broke on your leaf spring, allowing the axle to shift. I would check that out and replace both front springs if not them all
Good call, center pin is definitely missing. Can't even see where it should go. Any ideas on how to fix that? Thinking about suspending the body on something, pulling the U-bolts and jacking the axle up. Then I could slide it to where it goes and drop a new bolt through itů I know. I need new springs. I'll get around to it.

I was at DLI.

Finally got to do some work on it this weekend with a buddy. Replaced the steering damper. Old one didn't have any resistance. Bushings are all missing from the links, anywhere I can get those? Steering damper helped the play in the steering. Also replaced the valve cover gasket which cut down on oil leakage but I found a new problem. Whenever the vehicle is on there is a very steady drip coming from between the oil pan and the drive shaft cover. Thinking I may need to replace the oil pan, either that or if there is a gasket up there I may be able to just replace that but it sounds like somewhat of a project.

And what is the deal with the radiator. Heard other people have had problems with them falling apart. Mine looks like it is full of rust and maybe other things. Does it need to be replaced or can I just flush and refill.

Finally, figured out how to clean my air filter and that helped the performance considerably. Idles smoother and doesn't choke out as easily.

If anyone has ideas about the oil leak could use the input, leaking quite a lot while vehicle is on.

rbjackson is offline   Quote Quick Reply
Old 09-22-2010, 03:05 AM   #32
Supporting Member

WF Supporting Member
 
Crso8541's Avatar
 
Join Date: Sep 2010
Location: Clarksville, Tn
Posts: 266
there is a good parts jeep in wahiawa. i have the guys number if you need it. its a 89 yj you can go pull the parts or they can. it has a 3.5" lift leafs and shackles that are in good cond. if you need some help with the column let me know, i just rebuilt mine this weekend.

my radiator was falling apart, i thought it was working until i found that my engine was running at 160 without a thermostat. something else you should probably check for. i was not running with one and didnt' realize it. when i did finally realize it and put one in, the radiator wasn't working.

Crso8541 is offline   Quote Quick Reply
Old 09-22-2010, 08:11 PM   #33
Jeeper
 
Join Date: Sep 2010
Location: Wahiawa, HI
Posts: 31
I've seen that jeep on craigslist. Ill probably go check it out. Thanks
I think I have a working thermostat, probably should check it.

rbjackson is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
jeep wrangler 2002 hard starting problems jeeperson TJ General Discussion Forum 6 03-11-2012 09:25 PM
Fellow Ohio Jeepers Help fick15 Ohio Jeep Forum 11 01-19-2010 10:56 PM
I have major jeep problems please assist BlueGoat TJ Tech Forum 8 11-17-2009 10:51 AM
Chryseler Announces Prices for 2010 Geoff@Bestop Off-Topic 13 08-20-2009 11:10 PM
New (old) Jeep problems xrobbx03 YJ Tech Forum 3 11-12-2007 12:01 AM



» Featured Product

All times are GMT -5. The time now is 11:22 AM.



Jeep«, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC