2.5 liter motor problems? - Page 2 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-26-2012, 07:23 AM   #31
Newb
 
Join Date: Oct 2012
Posts: 4
Is that 30 psi hot or cold? 30psi is ok when hot but I've seen engines with shot bearings idle at 30 cold and near 0 hot.Something like 20-50 oil might help a little but if bearings are bad u got to replace them.

Yellow 90 is offline   Quote Quick Reply
Old 10-26-2012, 04:38 PM   #32
Jeeper
 
theblackyj's Avatar
 
Join Date: Aug 2012
Posts: 104
That was after it was hot.

theblackyj is offline   Quote Quick Reply
Old 10-27-2012, 07:02 PM   #33
Jeeper
 
89quest's Avatar
 
Join Date: Oct 2012
Location: conway,n.h
Posts: 374
Ibuildembig great post I had a suburu, 1996 and it started knocking and everyone said dump it ASAP.Turned out to be bad waterpump, the mechanic that done the work had fun lining the double overhead cams up, when he put it back together.This is the way remember it, I dont know that much aabout engines, just enough to get into really deep, stinky POOP!
89quest is offline   Quote Quick Reply
Old 11-01-2012, 03:07 PM   #34
Jeeper
 
theblackyj's Avatar
 
Join Date: Aug 2012
Posts: 104
Just a little update, I replaced my aftermarket cold air intake that the PO installed because there is a big hole right through the tube from it rubbing on the bracket. The filter that I thought was blue turned out that it was supposed to be white, ya probably not good. I also decided to change the plugs and wires. The filter changed the way that it ran drastically. It runs like it is new. The plugs and wires was just kind of a cheap and easy solution to try but they did not do much but is still good to do every once in a while. Still runs at 125 degrees but I am not to concerned about that anymore.

theblackyj is offline   Quote Quick Reply
Reply

Tags
motor advice , motor problem

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:51 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC