2.5 to 4.0 swap - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-23-2013, 11:07 PM   #1
Jeeper
 
maverick1979's Avatar
 
Join Date: Jun 2013
Posts: 105
2.5 to 4.0 swap

new to the wrangler world! i have a 93 yj wrangler base model 2.5 to 4.0 swap not going good at all got it all put together and now it will not start unless i jump the relay. i used the 4.0 wiring harness and ecm everything seem to work except the temp gauge and the no start by using the key any ideas on what it could be. oh ya the motor came out of a 95 wrangler

maverick1979 is offline   Quote
Old 06-24-2013, 08:35 AM   #2
Jeeper
 
wasomma's Avatar
 
Join Date: Aug 2010
Location: Baltimore, MD
Posts: 925
v8 wasn't an option?

Once you get it running does it run fine? Did you keep the Ax-5 tranny or swap to ax-15?

wasomma is offline   Quote
Old 06-24-2013, 08:54 AM   #3
Jeeper
 
Join Date: Jun 2013
Location: Mechanicsville, VA
Posts: 123
Good luck. Everyone i know who tried to do the same swap, as i was contemplating the same thing with my 4 banger, said don't do it or just swap in a V8 and be done with it....
Flyfisher76 is offline   Quote
Old 06-24-2013, 10:36 AM   #4
Jeeper
 
maverick1979's Avatar
 
Join Date: Jun 2013
Posts: 105
I swap it all.
maverick1979 is offline   Quote
Old 06-24-2013, 10:36 AM   #5
Jeeper
 
maverick1979's Avatar
 
Join Date: Jun 2013
Posts: 105
And yes it runs good
maverick1979 is offline   Quote
Old 06-24-2013, 10:44 AM   #6
Supporting Member

WF Supporting Member
 
western196611's Avatar
 
Join Date: Jun 2013
Location: Central Kansas
Posts: 724
When you say relay.. are you talking about jumping the starter cylinoid? Does it crank by the key at all?
__________________
1995, 4.0, 5 speed YJ, SOA, TC drop, 8.8 swap with 4.10 and LSD, e-grills bumper, 33" BF all terrains on 15" wheels.
western196611 is offline   Quote
Old 06-24-2013, 10:53 AM   #7
Supporting Member

WF Supporting Member
 
western196611's Avatar
 
Join Date: Jun 2013
Location: Central Kansas
Posts: 724
On mine there is a wire with a small (post type) connector that comes out of the harness close to the starter. Someone attached it to the starter. Mine would crank but not fire. Found the wire and put it to ground..... Bam, damn thing lit right off. It had been sitting for 2 years when I picked it up.
__________________
1995, 4.0, 5 speed YJ, SOA, TC drop, 8.8 swap with 4.10 and LSD, e-grills bumper, 33" BF all terrains on 15" wheels.
western196611 is offline   Quote
Old 06-24-2013, 12:09 PM   #8
Jeeper
 
maverick1979's Avatar
 
Join Date: Jun 2013
Posts: 105
No it will not crank by key everything power up but will not turn over. I pull the relay and use a pice of wire to start it.
maverick1979 is offline   Quote
Old 06-24-2013, 01:06 PM   #9
Jeeper
 
maverick1979's Avatar
 
Join Date: Jun 2013
Posts: 105
Did a little wire swap put the 2.5 main fuse block on and now it turns over just won't start. Looks like its not a plug and drive
maverick1979 is offline   Quote
Old 06-24-2013, 01:18 PM   #10
Supporting Member

WF Supporting Member
 
western196611's Avatar
 
Join Date: Jun 2013
Location: Central Kansas
Posts: 724
I'm scratching my head on this one...Have you looked... while cranking now, do you have spark?
__________________
1995, 4.0, 5 speed YJ, SOA, TC drop, 8.8 swap with 4.10 and LSD, e-grills bumper, 33" BF all terrains on 15" wheels.
western196611 is offline   Quote
Old 06-24-2013, 01:29 PM   #11
Jeeper
 
maverick1979's Avatar
 
Join Date: Jun 2013
Posts: 105
Not yet . When I track do the wire out of the main it was a yellow wire that runs to the middle of jeep and goes throw the fire wall and plug into what looks the dash cluster plug that's on the 4.0 harness on the 2.5 it goes to the fuse box on the driver side of jeep so did they change the wire on the 95 4.0
maverick1979 is offline   Quote
Old 06-24-2013, 07:48 PM   #12
Jeeper
 
maverick1979's Avatar
 
Join Date: Jun 2013
Posts: 105
No spark. MF
maverick1979 is offline   Quote
Old 06-27-2013, 11:37 AM   #13
Jeeper
 
maverick1979's Avatar
 
Join Date: Jun 2013
Posts: 105
Found out some info if you do a swap you have to use the 2.5 harness and wire in the other two injectors not bad at all
maverick1979 is offline   Quote
Old 06-29-2013, 12:20 PM   #14
Jeeper
 
bruceandjo95yj's Avatar
 
Join Date: Oct 2011
Location: London,Ont
Posts: 227
This might be a dumb answer..sorry not trying to offend anyone...but did you make sure your battery is charged..Only say this because when I first bought my jeep..drove it off the trailer..
removed the front fenders,battery..bat tray...and so on...it sat for a few days and after I got it all back together it wouldnt start for sh@T..
I was getting power to everything,radio worked.gauges all moved...couldnt figure for the life of me what was wrong.
Whole time my battrey had enuff juice to run the electronics but not turn over the engine.

Sometimes I over think stuff..other times I'm just a dumA@@ lol
__________________
My slow and low budget resto http://www.wranglerforum.com/f8/slow...ng-143787.html
bruceandjo95yj is offline   Quote
Old 06-29-2013, 04:13 PM   #15
Jeeper
 
maverick1979's Avatar
 
Join Date: Jun 2013
Posts: 105
New battery
maverick1979 is offline   Quote
Old 06-30-2013, 08:48 PM   #16
Jeeper
 
maverick1979's Avatar
 
Join Date: Jun 2013
Posts: 105
Quote:
Originally Posted by Flyfisher76 View Post
Good luck. Everyone i know who tried to do the same swap, as i was contemplating the same thing with my 4 banger, said don't do it or just swap in a V8 and be done with it....
Got it done it was easy just takes some time and I'm not good with wiring at all but got it done and runs great thanks for all the help guys and gals

maverick1979 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:49 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC